After upgrading Lubuntu 12.04 to lubuntu 14.04 the video driver does not load

Asked by wannabeelinux on 2014-11-05

I have upgraded a lubuntu laptop from 12.04 to 14.04 with do-release-upgrade command. After the upgrade only the standard driver will load instead of the normal video driver. The laptop is an EasyNote Packard Bell Alp Ajax C3 with a Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10). All other hardware seems to work normal. To resolve this I reinstalled lubuntu 12.04 from scratch. Is there a better way to do this?

Kind regards,

Bas Douma

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:

If 12.04 works then why change it? It still has 3 years support.

You could try a clean install of Trusty rather than the upgrade. May help. Those SiS GPUs are far from friendly.

wannabeelinux (bas-douma) said : #3

Thanks for the quick reply Andrew. I know 12.04 has still three years support but I hoped to use the working drivers of Precise Pangolin in Trusty Tahr, apparently it does not work that way in lubuntu. A clean install give the exact same result as the upgrade. But I like to think that upgrading in an early stage has the advantage of long support and use of the new features. Is there a way how I can do this with and stil use the old driver for the video adapter.

The only way i have seen those SiS GPUs work is by painfully formulating an xorg.conf file. It's old school but should work

wannabeelinux (bas-douma) said : #5

Thanks actionparsnip, that solved my question.