latest 12.10 upgrade caused webcam, usb ports, and nvidia optimus to stop working and power management issues on Samsung 700Z5C

Asked by Gabriel Claramunt on 2013-01-22

Last friday I updated the kernel and linux-libc-dev and after that, I noticed:
webcam is not recognized anymore
one of the usb ports doesn't work
bumblebee for nvidia optimus doesn't run
Other minor issues regarding power management (ACPI irqs, keyboard backlight, etc )
The power management issues seem related to /etc/default/grub being overwritten.

I've booted a previous version of the kernel from the boot menu but the problem still persists.

The laptop is a Samsung series 7 Chronos 700Z5C-S02UB

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Gabriel Claramunt
Solved:
2013-01-24
Last query:
2013-01-24
Last reply:
2013-01-23
N1ck 7h0m4d4k15 (nicktux) said : #1

Try to reinstall nvidia drivers and bumblebee package.

Reinstalling Nvidia

sudo apt-get install --reinstall nvidia-current nvidia-settings
sudo rm /etc/X11/xorg.conf
sudo nvidia-xconfig

Reinstalling Bumblebee

sudo rm /etc/bumblebee/bumblebee.conf
sudo apt-get install --reinstall bumblebee bumblebee-nvidia linux-headers-generic

Reboot your system and see if fixed.

BE AWARE in first set of commands (nvidia-reistallation) replace the nvidia-current IF you have another version of nvidia driver installed. (eg. nvidia-experimental-310 ... because I don't know what version of nvidia driver you have.)

Thanks

Thanks a lot, but tried that and didn't work... and the issue is not particular to the video driver either. The latest kernel upgrade seems to have borked up the configuration

If you boot the Quantal liveCD, is it ok?

N1ck 7h0m4d4k15 (nicktux) said : #4

The kernel is just a package like all others. If you boot from an older kernel , do you have a problem ?

The /etc/default/grub config file you said in the description is not change with a kernel update , only with grub update.

Kernel update , will install new modules and headers , it will not corrupt any configuration , so if you boot from an older kernel the new installed kernel is not affect the older.

Thanks

Strange, I've reinstalled everything and with 3.5.0.17 works, it doesn't with 3.5.0.18 and 3.5.0.19 , but I've upgraded to 3.5.0.22 and works fine.

Previously it didn't work even with older kernels.

I know the kernel is "just another package" and previously I had trouble-free upgrades.
Still, every time a new kernel is installed, the grub config is updated, right? Somehow, something went wrong...

N1ck 7h0m4d4k15 (nicktux) said : #6

Yes , not the grub configuration file , but the grub entries are updated.

Ok , glad you solved it.