How to change monitor settings?

Asked by John Hill on 2013-01-07

I'm trying to install Ubuntu 12.04 LTS - replacing Ubuntu 10.04, but my monitor settings are such that the bottom section of the pages are not visible, hence I can't progress with the installation until I get the Ubuntu 12.04 recommended monitor setting - 1920 x 1080 at 60Hrz or similar in place.
How do I achieve a monitor setting change with Ubuntu 12.04 in RAM? I must admit the desktop is a bit of a puzzle to me at this stage.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
John Hill
Solved:
2013-01-12
Last query:
2013-01-12
Last reply:
2013-01-08
Thomas Krüger (thkrueger) said : #1

In most cases the graphic card queries the monitor for the display modes it supports and sets everything to the best supported settings. In some cases that does not work well.

Maybe the settings of the monitor are not properly. You should try to start the automatic configuaration from monitors OSD.
If that still does not help help run the following line in the terminal, wait for completion and copy the full output for us!

xrandr; sudo lshw -c display

This Tusooa (tusooa) said : #2

Launch System Settings and you can change the settings of display.

John Hill (johnh) said : #3

Can't initiate auto configuration. Can select a more appropriate configuration using Launch System Settings and Display settings - but it is not accepted!

custom@custom:~$ xrandr; sudo lshw-c display
Screen 0: minimum 320 x 200, current 720 x 400, maximum 4096 x 4096
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 720x400+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1280x1024 75.0 60.0
   1440x900 59.9
   1280x960 60.0
   1280x800 59.8
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1*
TV-1 disconnected (normal left inverted right x axis y axis)
sudo: lshw-c: command not found
custom@custom:~$

custom@custom:~$ xrandr; lshw-c display
Screen 0: minimum 320 x 200, current 720 x 400, maximum 4096 x 4096
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 720x400+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1280x1024 75.0 60.0
   1440x900 59.9
   1280x960 60.0
   1280x800 59.8
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1*
TV-1 disconnected (normal left inverted right x axis y axis)
lshw-c: command not found
custom@custom:~$

If the l is not an L in lower case, ie a vertical line, I can't generate that from the PC keyboard I trying to install Ubuntu 12.04 to.

Cheers John

Thomas Krüger (thkrueger) said : #4

Please note that there is a space between "lshw" and "-c"! It's important. Please run the last part again:

lshw -c display

But from the first part of the output I can already see, that your monitor does not support 1080p (1920×1080) as you stated. Or at least is not report that. What brand and model is the display?

John Hill (johnh) said : #5

custom@custom:~$ sudo lshw -c display
  *-display
       description: VGA compatible controller
       product: NV34 [GeForce FX 5500]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=32 maxlatency=1 mingnt=5
       resources: irq:16 memory:de000000-deffffff memory:c0000000-cfffffff memory:dfee0000-dfefffff
custom@custom:~$

Monitor is a Samsung Syncmaster 2233 SW.

Further info: During the loading for the DVD the monitor is put into an appropriate setting - which would display full pages with ease. During this phase a message box appears stating: Not Optimum Mode: Recommended Mode: 1920x1080 60 Hz. However just prior to displaying the commencement of the desktop the monitor settings change significantly - resulting in only say 70% of the page being displayed. During shut down the reverse occurs, once the sequence get out of the desktop display the monitor settings revert to a more appropriate setting plus the message Not Optimum Mode: Recommended Mode: 1920x1080 60 Hz.

I'm aware the recommended setting is not available but something approaching that would do fine.

Can't initiate auto configuration. Can select a more appropriate configuration using Launch System Settings and Display settings - but because the APPLY button is not available to achieve this. Using Enter has no effect.

Most frustrating. Is there a means via Terminal that could achieve the required monitor setting?

Thomas Krüger (thkrueger) said : #6

You are using the nouveau open source driver on a rather old nVidia card. This can lead to some problems.
LAter on the installed system I recommend installing the proprietary driver "nvidia-173".

So far you can use the tool "xrandr" on the terminal (in a graphic environment) to change the display settings.
Try to run this (copy it into the terminal) and report the result:

xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
xrandr --addmode DVI-I-1 1920x1080_60.00
xrandr --output DVI-I-1 --mode 1920x1080_60.00

John Hill (johnh) said : #7

Running the above in terminal resulted in a black screen.
The 1st line had no obvious impact.
2nd line resulted in the black screen.

What about doing the same for 1440 x 900 or 1280 x 800 - both of which are supported by the nVidia card?

John Hill (johnh) said : #8

Thomas, what changes to the script are needed (see 2013-01-08) to achieve 1440 x 900 or 1280 x 800 monitor setting from Terminal - both of which are supported by the nVidia card?
Just changing the setting results in a black screen.

John Hill (johnh) said : #9

Have the problem sorted. Installation of Ubuntu 12.04 from DVD necessitated a restore of 10.04 via Clonzilla - and then updated to 12.04 via the net. Had the opportunity to change monitor setting at completion of installation - and to update to the proprietary driver "nvidia-173.
Thanks Thomas for your help.