12.04 boot after updates but no screen

Asked by Gord Fisch on 2013-01-04

Studio Ubuntu 12.04.1

Using Nvidia GeForce GTX 550

Has run fine for 6 months

After updates and reboot I see nothing. It boots with no graphics, no text. Loads my printer driver as I hear the printer reloading. Alt F2 gives be a terminal.
I try to 'sudo su -' and the error is "sudo must be setuid root"
/usr/bin/sudo has owner:group gord:gord

I tried booting from a CD, mounted drive and ran
chmod 4755 /mnt/usr/bin/sudo
and rebooted.

No change.

I try startx and the error is
Cannot open /dev/tty0 (No such file or directory

Question information

English Edit question
Ubuntu xserver-xorg-video-nv Edit question
No assignee Edit question
Solved by:
Gord Fisch
Last query:
Last reply:
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

You said after update , maybe a kernel update ?

Try to boot from a previous kernel (previous Linux versions on grub menu).


Revision history for this message
actionparsnip (andrew-woodhead666) said :


sudo -I

Instead of sudo su.

Did you install the proprietary video driver?

Revision history for this message
actionparsnip (andrew-woodhead666) said :


sudo -i


Revision history for this message
Gord Fisch (b-gord) said :

Yikes! It was a backup script gone bad that chown most of the computer to my account.

After a few hours of chowning (mostly to root:root) I am back in business.
It helped to boot from a disk and
chown root:root /usr/sbin/sudo
chmod 4755 sudo then reboot.

chmod 4755 /usr/bin/Xorg gave my user graphics again

Thanks for looking in,