Can't change screen resolution in nvidia-settings (only 1680x1050 option available)

Asked by Tulejumal on 2012-12-27

Can anyone tell me what's the problem?
Why doesn't nvidia-xconfig add other screen resolutions?
Is it a bug with the drivers?
Can't lower the resolution in games too.

My xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 313.09 (buildd@chindi10) Wed Dec 12 17:17:03 UTC 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 310.14 (buildmeister@swio-display-x86-rhel47-11) Tue Oct 9 12:15:25 PDT 2012

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Files"
    FontPath "unix/:7100"
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

 # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Chi Mei Optoelectronics corp."
    HorizSync 30.0 - 75.0
    VertRefresh 59.9
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8600M GT"
    Option "NoLogo" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Coolbits" "1"
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-0"
    Option "metamodes" "nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-12-28
Last query:
2012-12-28
Last reply:
2012-12-28

Run:

gksudo nvidia-settings

Set the resolution and refresh rate to something, click 'Save to X config file'. Then run:

gksudo gedit /etc/X11/xorg.conf

Set the res as you want.

Tulejumal (tulejumal-sid) said : #2

I triedthat, but no success.

My xrandr output:

viktor@viktor-N-A:~$ xrandr
Screen 0: minimum 8 x 8, current 1680 x 1050, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
TV-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050 59.9*+
viktor@viktor-N-A:~$

What is the output of:

lsb_release -a; uname -a; apt-cache policy nvidia-current

Thanks

Tulejumal (tulejumal-sid) said : #4

viktor@viktor-N-A:~$ lsb_release -a; uname -a; apt-cache policy nvidia-current
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux viktor-N-A 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:19:45 UTC 2012 i686 i686 i386 GNU/Linux
nvidia-current:
  Installed: 313.09-0ubuntu1~xedgers~precise1
  Candidate: 313.09-0ubuntu1~xedgers~precise1
  Version table:
 *** 313.09-0ubuntu1~xedgers~precise1 0
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     304.64-0ubuntu1~precise~xup1 0
        500 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ precise/main i386 Packages
     295.40-0ubuntu1.1 0
        500 http://ee.archive.ubuntu.com/ubuntu/ precise-security/restricted i386 Packages
        500 http://ee.archive.ubuntu.com/ubuntu/ precise-updates/restricted i386 Packages
     295.40-0ubuntu1 0
        500 http://ee.archive.ubuntu.com/ubuntu/ precise/restricted i386 Packages
viktor@viktor-N-A:~$

Then you are using a PPA for the driver. I suggest you contact the PPA maintainer.

Tulejumal (tulejumal-sid) said : #6

Thanks actionparsnip, that solved my question.