Boot and shutdown in text only mode, after upgrade to Ubuntu 12.10

Asked by Debbie on 2012-12-08

When I start the computer there is flashing black screen, followed by a blank purple screen, then the login appears. I do see very briefly the words Ubuntu 12.10 but it is in text only, not the graphical feature. Also when I shutdown I get text, not the logo, and a flashing cursor to the left of the screen. The text is about the process of shutdown. I am using Nvidia G220 graphics card and with Nvidia proprietry tested binary Xorg drivers. So if these drivers are being loaded onto the system, why am I getting this problem at shutdown as well?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Debbie
Solved:
2012-12-11
Last query:
2012-12-11
Last reply:
2012-12-08

The nvidia driver doesn't get loaded fast enough so you get no plymouth splash. Usually the shutdown is ok as the drivers are already loaded.

Debbie (deborah-poole) said : #2

So if the drivers are loaded, and they are, what's the difference? It's still the same when I shutdown i.e. no Plymouth splash. Do the nvidia drivers shutdown before the final screen comes up, or what?

Its a weird on. Have you tried a different splash?

Debbie (deborah-poole) said : #4

Well I noticed in the software centre I have the logo and the text theme ticked. I tried to correct this by un-checking the text one, rebooted and found I had no Ubuntu 12.10 on display at all at startup. I realised then that it was because the graphical display wasnt working so I went into the software centre and put the tick back again. That was all before I read your suggestion immediately above.

How can I get a different splash?

Debbie (deborah-poole) said : #5

I installed the SuperBoot Manager like so;

sudo add-apt-repository ppa:ingalex/super-boot-manager

sudo apt-get update

sudo apt-get install super-boot-manager

I chose the 'Sunrise' and set as default in the termninal then applied changes. No good whatsoever.
What I did notice however was that when I previewed the splash, it showed two windows, differenet sizes and quite a bit smaller than the size of my screen.

Debbie (deborah-poole) said : #6

By "no good whatsoever" I mean that I was still seeing the text at boot and shutdown.

Debbie (deborah-poole) said : #7

I have changed the drivers from proprietry Nvidia to Nouveau and now I get the Plymouth splash at shutdown which I was really pleased to see.

However, on startup, the purple screen has now become stable, with no flashing black screens, but then after several seconds a thick black line appears just before the login window. Any thoughts as to how to fix this please?

Debbie (deborah-poole) said : #8

Installation of Nvidia Experimental 304 has solved my problem. Plymouth display works fine now in both instances.