graphic card driver stop working

Asked by Tonyt on 2012-11-25

After recent software updates .the graphic card drivers of stop working only get 800x 600 resolution....the graphic card is a...
ASUS EN210 SILENT/DI/1GD3/V2(LP
...........................................................................
at boot up get the following message
could not apply the stored configuration for monitor
none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 373
CRTC 373: trying mode 2560x1024@50Hz with o
utput at 1280x1024@51Hz (pass 0)
CRTC 373: trying mode 2560x1024@51Hz with output at 1280x1024@51Hz (pass 0)
CRTC 373: trying mode 2560x1024@50Hz with output at 1280x1024@51Hz (pass 1)
CRTC 373: trying mode 2560x1024@51Hz with output at 1280x1024@51Hz (pass 1)
...........................................................................................................................................................

When open the nvidia terminal/manger get the following message

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.Sorry, installation of this driver failed.

....................................................................................................................................................................
tryed to install additional drivers for the graphics get the following

Please have a look at the log file for details: /var/log/jockey.log
Sorry, installation of this driver failed.

is a 64 bit system ubuntu 12.04 dual booted with windows 7

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-11-27
Last query:
2012-11-27
Last reply:
2012-11-27

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Tonyt (tonys666) said : #2

as requested
o@o-N68S3:~$ sudo lshw -C display
[sudo] password for o:

  *-display UNCLAIMED
       description: VGA compatible controller
       product: GT218 [GeForce 210]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:df000000-dfffffff memory:c0000000-cfffffff memory:dc000000-ddffffff ioport:ec00(size=128) memory:def80000-deffffff
...........................................................

o@o-N68S3:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
...............................................................................

o@o-N68S3:~$ uname -a
Linux o-N68S3 3.2.0-34-generic-pae #53-Ubuntu SMP Thu Nov 15 11:11:12 UTC 2012 i686 athlon i386 GNU/Linux

....................................................................................................

o@o-N68S3:~$ dpkg -l | grep nvidia
ii nvidia-current 304.64-0ubuntu1~precise~xup1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 304.64-0ubuntu1~precise~xup1 Tool of configuring the NVIDIA graphics driver
o@o-N68S3:~$

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #3

Hi ,
please open a terminal ONLY (CTRL+ALT+T) and execute bellow commands one at time. All the "job" here will take place through terminal.

~$ sudo apt-get purge nvidia-*

~$ sudo apt-get install ppa-purge

~$ sudo ppa-purge ppa:ubuntu-x-swat/x-updates

~$ sudo apt-get update

~$ sudo rm /etc/X11/xorg.conf

~$ sudo apt-get install nvidia-current

~$ sudo nvidia-xconfig

Reboot your PC.

Thanks

When people give you a command, please don't break it up. Just copy it as given and run it as given.
Thanks

Tonyt (tonys666) said : #5

tryd entering the terminal commands got back the Nvidia Xserver terminal/manager but only get two resolutions 640 x 480 or 320 x 240 and

still get at boot up get the following message
could not apply the stored configuration for monitor
none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 373
CRTC 373: trying mode 2560x1024@50Hz with o
utput at 1280x1024@51Hz (pass 0)
CRTC 373: trying mode 2560x1024@51Hz with output at 1280x1024@51Hz (pass 0)
CRTC 373: trying mode 2560x1024@50Hz with output at 1280x1024@51Hz (pass 1)
CRTC 373: trying mode 2560x1024@51Hz with output at 1280x1024@51Hz (pass 1)

at boot up

Thanks

What is the output of:

sudo lshw -C display; dpkg -l | grep nvidia

Thanks

Tonyt (tonys666) said : #7

o@o-N68S3:~$ sudo lshw -C display; dpkg -l | grep nvidia
[sudo] password for o:
  *-display
       description: VGA compatible controller
       product: GT218 [GeForce 210]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:19 memory:df000000-dfffffff memory:c0000000-cfffffff memory:dc000000-ddffffff ioport:ec00(size=128) memory:def80000-deffffff
ii nvidia-current 295.40-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
o@o-N68S3:~$

Thanks

Ok, run:

gksudo nvidia-settings

Set the resolution and refresh rate to something and click 'Save to X config file'

Then run:

gksudo gedit /etc/X11/xorg.conf

Set the resolution to what you desire in the file, save the new file and close gedit. Reboot to test.

If that fails. Hold SHIFT at boot, select recovery mode and select root and run:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old

Note the X in X11 is capitalized. You can then run:

reboot

To get to the desktop. You may benefit from:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

Reboot to test

N1ck 7h0m4d4k15 (nicktux) said : #10

Please READ the description about xorg-edgers PPA : https://launchpad.net/~xorg-edgers/+archive/ppa

Is ok to add the PPA but you have to know what is :-)

Thanks

True but the 310 driver is known to improve speeds no-end :). Its simple to remove too.

Tonyt (tonys666) said : #12

using the gedit file etc had no effect after root booting

Tryed the nxt eg If that fails. Hold SHIFT at boot, select recovery mode and select root and run:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old

States mv is a missing destination file operand after

Tonyt (tonys666) said : #13

Tryed what you sugguested still have the same problem except have got back the x server terminal/manager back and only the same to resolutions

N1ck 7h0m4d4k15 (nicktux) said : #14

Have you tried to boot from another kernel ?

Maybe this is a bug with new kernel (you said after updates problem occurred) and nvidia module (driver).

Try to boot from an older kernel "Previous Linux Versions" at grub menu.

Thanks

Tonyt (tonys666) said : #15

thanks have tryed that as well still no good

Best N1ck 7h0m4d4k15 (nicktux) said : #16

man.. this is weird..

Have you tried without nvidia-driver(s) ?
nouveau (open source nvidia driver , the pre-installed) is a good driver also.

Try this

~$ sudo apt-get remove --purge nvidia-*

~$ sudo rm /etc/X11/xorg.conf

~$ sudo apt-get install nvidia-common ubuntu-desktop

~$ sudo apt-get install --reinstall xserver-xorg-video-nouveau

~$ sudo dpkg-reconfigure xserver-xorg

and then reboot your PC and see if working.

Thanks

Tonyt (tonys666) said : #17

Thanks NikTh, that solved my question.