Run nvidia latest driver on 12.10 Unity crashed

Asked by Boddin A on 2012-11-20

Hi,

I tried to install NVIDIA latest driver on Ubuntu 12.10 running below commands:-

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Reboot the system.

After rebooting, Unity/LaunchPad/Dash crashed and could not be recovered. Tried the Superkeys but to no avail.

Re-run Ubuntu installation overwrite the previous installation and get a clean Ubuntu 12.10 back to normal.

Reason to install latest driver for NVIDIA as the screen brightness could not be adjusted properly even using the Function key to reduce/increase brightness. Overall it impacted my laptop's battery performance.

My laptop config as per below:-
RAM - 4GB
Processor - Intel Core i5-2410M CPU@2.30GHzx4
Graphics - NVIDIA Geforce GT520M
OS - 32 bit Ubuntu 12.10 Desktop

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-20
Last reply:
2012-11-20

You have a switchable video chip and this doesn't work well at all in Linux. I have never seen a success story with this mess and it is best avoided. This link may help:
https://help.ubuntu.com/community/HybridGraphics

Using the Edgers PPA is not advised for casual use, it is highly experimental and very very unstable.

Boddin A (boddin) said : #2

I run this command :-

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Output as per below:-

bob@G5047:~$ sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia
[sudo] password for bob:
  *-display
       description: VGA compatible controller
       product: GF119 [GeForce GT 520M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:2000(size=128)
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:48 memory:f1000000-f13fffff memory:e0000000-efffffff ioport:3000(size=64)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux G5047 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19 10:27:31 UTC 2012 i686 i686 i686 GNU/Linux
bob@G5047:~$

Boddin A (boddin) said : #3

Can I experiment below project? Mine is actually NVIDIA Optimus type with model Cuda 1GB

Bumblebee Project - https://wiki.ubuntu.com/Bumblebee

Bumblebee aims to provide support for NVIDIA Optimus laptops for GNU/Linux distributions. Using Bumblebee, you can use your NVIDIA card for rendering graphics which will be displayed using the Intel card.

Boddin A (boddin) said : #4

I run below commands to see what is the Graphic card details displayed at System Settings-

It displays as - IntelĀ® Sandybridge Mobile x86/MMX/SSE2

bob@G5047:~$ sudo apt-get install mesa-utils
[sudo] password for bob:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.5.0-17 linux-headers-3.5.0-17-generic
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  mesa-utils
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.6 kB of archives.
After this operation, 135 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ quantal/universe mesa-utils i386 8.0.1+git20110129+d8f7d6b-0ubuntu2 [27.6 kB]
Fetched 27.6 kB in 2s (13.8 kB/s)
Selecting previously unselected package mesa-utils.
(Reading database ... 178517 files and directories currently installed.)
Unpacking mesa-utils (from .../mesa-utils_8.0.1+git20110129+d8f7d6b-0ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Setting up mesa-utils (8.0.1+git20110129+d8f7d6b-0ubuntu2) ...
bob@G5047:~$

Can you help with this problem?

Provide an answer of your own, or ask Boddin A for more information if necessary.

To post a message you must log in.