CPU locks up and temperature increases

Asked by Brian Marine on 2012-11-16

Yesterday while i was using my laptop with two chromium web browsers, skype, and banshee media player running my cpu got to about 73% and wouldnt decrease even after i closed everything, the parts of my laptop got to about 86C at the max, the only thing thast worked was to suspend it and let it cool down, then the cpu was fine again. The only modifications i made to ubuntu was the swappiness, used bleachbit and have zram.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
Brian Marine (crysisfreak7) said :
#1

im runing those same programs right now and if i dont touch anything the cpu gets down to 9%, also i dont know if this will help but i have intel centrino vpro 2 dual core that gets 2.24 ghz and i have 3 gigs of ram and an nvidia Quadro NVS 150M but my laptop was bought of ebay used and i have had it for about 2 or 3 years and it previously had windows vista buisness 32 bit.

Revision history for this message
Brian Marine (crysisfreak7) said :
#2

the current temp ratings

temp 1 50 C
core 0 36 C
core 1 40 C
/dev/sda 33 C
GPU0 55 C
cpu usage 9% (13% when typing)

Revision history for this message
Brian Marine (crysisfreak7) said :
#3

also sorry for the constant updates but i forgot to mention i already have a laptop cooling fan, it is conected to a four port usb hub

Revision history for this message
Brian Marine (crysisfreak7) said :
#4

again sorry for the constant upload of more info, i also must say that right now i have my nvidia proprietary driver set to adaptive performance mode and i installed jupiter and set that to power saver. to avoid overheating

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

what is the make and model of the system????

Revision history for this message
Brian Marine (crysisfreak7) said :
#6

the laptop= Toshiba tecra m10
cpu= intel centrino vpro 2 dual core
gpu= nvidia Quadro NVS 150M
ram= 3 gigs / 2 chips = 1.5 gig chips
as for other info
ubuntu version 12.10 quantal quetzal 32 bit
6 gigs swap space though for some reason it wont auto mount on boot up and it still says i have 1.5 gigs swap
bios= toshiba (of course)

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7

Can you give the output of:

sudo lshw -C display

Thanks

6Gb swap is a bit excessive. You only need about 3.3Gb but you'll probably have enough space to not care

Revision history for this message
Brian Marine (crysisfreak7) said :
#8

  *-display
       description: VGA compatible controller
       product: G86M [Quadro NVS 150M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fd000000-fdffffff memory:e0000000-efffffff memory:fa000000-fbffffff ioport:cf00(size=128) memory:fc000000-fc01ffff

Revision history for this message
Brian Marine (crysisfreak7) said :
#9

yeah i havent noticed the swap partition ever being used so i just set swappiness to 1 just incase it does need to be used one day

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#10

Good call. What is the output of:

dpkg -l | grep nvidia

Thanks

Revision history for this message
Brian Marine (crysisfreak7) said :
#11

rc libkwinnvidiahack4 4:4.9.2-0ubuntu2.1 i386 library used by nvidia cards for the KDE window manager
rc nvidia-173 173.14.35-0ubuntu0.2 i386 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-cg-dev:i386 3.1.0013-1 i386 Cg Toolkit - GPU Shader Authoring Language (headers)
ii nvidia-cg-toolkit 3.1.0013-1 i386 Cg Toolkit - GPU Shader Authoring Language
ii nvidia-common 1:0.2.71.1 i386 transitional package for ubuntu-drivers-common
ii nvidia-current 304.51.really.304.43-0ubuntu1 i386 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 304.51-0ubuntu2 i386 Tool for configuring the NVIDIA graphics driver

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#12

ok let's clean this up:

sudo dpkg -P libkwinnvidiahack4 nvidia-173

Do you use the Cg toolkits you have installed?

Revision history for this message
Brian Marine (crysisfreak7) said :
#13

no i dont program anything that would require it so no. also is enabling fxaa in the antialiasing settings going to speed things up?

Revision history for this message
Brian Marine (crysisfreak7) said :
#14

the closest thing i do to programing is 3d modeling using blender

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#15

sudo apt-get --purge remove nvidia-cg-dev:i386 nvidia-cg-toolkit nvidia-current nvidia-settings

sudo apt-get --purge autoremove

Reboot then reinstall the driver. May help

Revision history for this message
Brian Marine (crysisfreak7) said :
#16

my cpu hasnt locked yet thanks.

Revision history for this message
Brian Marine (crysisfreak7) said :
#17

Thanks actionparsnip, that solved my question.