"the system is running in low graphics mode" screen comes up when powering up

Asked by John Rianda on 2012-11-15

when turning on my computer it takes many tries before I can get to a log in screen, it shows an error screen that says: "The system is running in low graphics mode. Your screen, graphics card and input device settings could not be detected correctly. You will need to configure these yourself." if I try to reboot it usually comes up a second time and then on the third try a screen will come up that says: "GNU GRUB Version 1.99-21 Ubuntu 3.4" and allows 5 choices starting with: "Ubuntu Linux 3.2.0-32-generic-pae" which is what I choose. Sometimes when I get logged in finally the internet is not connected and I have to start all over.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
John Rianda
Solved:
2012-11-17
Last query:
2012-11-17
Last reply:
2012-11-17

This question was reopened

N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,
what is your graphics card and what drivers you use ? Do you remember if you installed any additional driver for your card ?

If you can , give these results (open a terminal with CTRL+ALT+T keys combo and paste bellow commands)

~$ lspci -nnk | grep -iA2 vga

~$ lsb_release -rcd ; uname -r

~$ dpkg -l | grep -ie fglrx -ie nvidia

Thanks

John Rianda (jhrianda) said : #2

00:10.0 VGA compatible controller [0300]: NVIDIA Corporation C73 [GeForce 7100 / nForce 630i] [10de:07e1] (rev a2)
 Subsystem: Biostar Microtech Int'l Corp Device [1565:1407]
 Kernel driver in use: nvidia

Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
3.2.0-32-generic-pae

ii nvidia-common 1:0.2.44.2 Find obsolete NVIDIA drivers
ii nvidia-current 295.40-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

N1ck 7h0m4d4k15 (nicktux) said : #3

Try

~$ sudo apt-get purge nvidia-*

~$ sudo rm /etc/X11/xorg.conf

~$ sudo apt-get install ubuntu-desktop

~$ sudo apt-get install --reinstall xserver-xorg-video-nouveau

~$ sudo dpkg-reconfigure xserver-xorg

~$ sudo reboot

Is it OK now ?

Thanks

John Rianda (jhrianda) said : #4

first command showed a lot on the screen.
second command showed:
rm: cannot remove `/etc/X11/xorg.conf': No such file or directory

N1ck 7h0m4d4k15 (nicktux) said : #5

OK , is not necessary to have this file. Proceed .

John Rianda (jhrianda) said : #6

went through them all and the secon to last command didn't seem to do anything. After the reboot the screen makes some little flashes when changing from one screen to the next but it went through the boot process without showing the low graphics message.

N1ck 7h0m4d4k15 (nicktux) said : #7

Lets see if you removed correctly the nvidia driver

~$ dpkg -l | grep -i nvidia

Thanks

John Rianda (jhrianda) said : #8

ii nvidia-common 1:0.2.44.2 Find obsolete NVIDIA drivers
john@john-desktop:~$

John Rianda (jhrianda) said : #9

One thing I'd like to mention is I'm running on ubuntu 2D before this switch my new 12.4 operating system was all buged up with no tool bar and sometimes showing a screen blank except for a band of pixle noise. So now after your fix the problem is still all these little flashes of stuff especially when the screen is changing.

John Rianda (jhrianda) said : #10

when I'm on certain sites like youtube the flashes are constant and are a flash of the current screen image shifted sideways six inches or about half the screen, example: I can see the toolbar flashing in the middle of the screen for split seconds when running youtube videos. Is there a way to fix this or go back to the way it was before?

John Rianda (jhrianda) said : #11

I entered the command you provided in #7 and the response is shown in #8,

thank you for your help thus far

I am still getting ghost images everywhere

John Rianda (jhrianda) said : #12

I am getting flashes of misplaced images everywhere when I run video and even with non video pages. I hope I didn't confuse things with comment #9 that was an old problem I was talking about, I just thought that may have some relavence to this problem but probably not, I'm a novice to all this, please help me if you can the problem of getting logged in is fixed but this problem with the flashing images makes viewing any video horrible.

Thank you

N1ck 7h0m4d4k15 (nicktux) said : #13

Hi,

lets install a newest driver trough PPA .

Open a terminal and do

~$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
~$ sudo apt-get update ; sudo apt-get dist-upgrade
~$ sudo apt-get install linux-headers-generic
~$ sudo apt-get install nvidia-current
~$ sudo nvidia-xconfig

Then reboot and see.

Thanks

John Rianda (jhrianda) said : #14

on the last command I got this:

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

N1ck 7h0m4d4k15 (nicktux) said : #15

This is normal...

Reboot cross hands and we will see. :-)

John Rianda (jhrianda) said : #16

Happy happy, joy joy. Problem Solved.

John Rianda (jhrianda) said : #17

The problem with the flashing images went away but the problem with the error page reading "The system is running in low graphics mode" has returned with a vengence. Usually after a few reboot trys it goes away but this time it took me many trys and sometimes shows a text screen. So I'm back to the original problem.

N1ck 7h0m4d4k15 (nicktux) said : #18

Try this command please

~$ echo 'nvidia' | sudo tee -a /etc/modules

and then reboot .

Thanks

John Rianda (jhrianda) said : #19

That worked well to solve the problem, however now sometimes when I log in to my desktop the file folder icons are missing and when I try to open foxfire the screen flashes but it never opens, seems like its trying to and even will say the name of my homepage sometimes at the top black line but there's nothing below just my desktop image with no browser opened so I have to reboot till the folders appear and then I can open foxfire. This actually started happening after the commands in #13 if I'm correct.

N1ck 7h0m4d4k15 (nicktux) said : #20

Hi ,
This is probably a problem for another question. You can try to reset your settings .
Commands I gave you in 13th answer , updated-upgraded your driver for graphics card.

If now run in terminal this command

~$ apt-cache policy nvidia-current

you will see that the installed driver is : 304.64-0ubuntu1~precise~xup1

That is the newest driver you can get , of course there is another PPA with more new driver , but I considered as too risky.

As I said , if your screen resolution is OK now , you can close this question (sovled by answer) and then open a new.
Also you can link this question to the new.

But before , you can try these 2 things

1) ~$ unity --reset

After above command done , you can reboot or logout - login.

2) To reset your system to the primary state (ALL your configurations will be LOST)

~$ rm -rf .compiz* .gconf* .config/dconf/ .config/compiz* .mozilla/

Reboot your system.

Thanks

John Rianda (jhrianda) said : #21

Thank you for your help, I had to make a second attempt to log in today but that's ok I guess it's a lot to ask to be bug free. If my dog has one flea I'm not going to give him a flea dip. I'll just leave things as is for now and be happy with the progress rather than risk more challenging bugs.