Graphics shows Unknown in Ubuntu 12.10

Asked by MBHAKM on 2012-11-11

In Ubuntu 12.10, System Settings --> Details --> Graphics shows unknown.

In Hardware --> Additional Drivers --> NVIDIA accelerated Graphics Driver (post-release updates) (version current -updates) driver is activated and currently in use.

Here is the information:
 lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: C51 [GeForce Go 6150]
       vendor: NVIDIA Corporation
       physical id: 5
       bus info: pci@0000:00:05.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:21 memory:b2000000-b2ffffff memory:c0000000-cfffffff memory:b1000000-b1ffffff memory:80000000-8001ffff

uname -a
Linux tgtsrv2012 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Please advise us what needs to be done to get it fixed for Graphics

Thanks & regards
MBHAKM

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-11-11
Last query:
2012-11-11
Last reply:
2012-11-11

What is the output of:

dpkg -l | grep nvidia

Thanks

MBHAKM (sapforsap) said : #2

Here is the outpiut of:

 dpkg -l | grep nvidia
rc nvidia-173 173.14.30-0ubuntu8.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-common 1:0.2.44.2 Find obsolete NVIDIA drivers
rc nvidia-current 295.40-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-current-updates 304.43-0ubuntu0.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
rc nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
ii nvidia-settings-updates 304.43-0ubuntu0.2 Tool of configuring the NVIDIA graphics driver

sudo apt-cache policy nvidia-current
nvidia-current:
  Installed: (none)
  Candidate: 295.40-0ubuntu1.1
  Version table:
     295.40-0ubuntu1.1 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise-updates/restricted amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/restricted amd64 Packages
        100 /var/lib/dpkg/status
     295.40-0ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise/restricted amd64 Packages

Thanks & regards
MBHAKM

Best N1ck 7h0m4d4k15 (nicktux) said : #3

You have to install mesa-utils package in order to "recognize" your graphics card in "Details"

~$ sudo apt-get install mesa-utils

Thanks

MBHAKM (sapforsap) said : #4

Thanks NikTh, that solved my question.