nvidia drivers not working

Asked by Neil on 2012-11-10

Hi all
got a problem,
just installed 12.10 but can not get nvidia drivers to work,
I have tried
synaptic and terminal, and Ubuntu software centre none work.

I installed Additional Drivers.. just for it not to be there after reboot.
says installed but no icon anywhere. so can't use it why is it not there to start with?

problem I'm having is
well no driver to start with, wont install on installation like 12.04. having internet on for updates.

After installing drivers I reboot. fan on graphic card still spinning at full speed.
I get the desktop ok. but wallpaper only no launchers at all.
I can right click and use the commands there, but changing wall paper is not a lot of fun.

how do I get it all working?
please help.
Thanks
Neil

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-11-11
Last query:
2012-11-11
Last reply:
2012-11-10
Best N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

please close all applications and open a terminal (CTRL+ALT+T) and copy-paste from here bellow commands with order. One line at time.

~$ sudo apt-get remove --purge nvidia-*
~$ sudo rm /etc/X11/xorg.conf
~$ sudo apt-get install linux-source
~$ sudo apt-get install linux-headers-generic
~$ sudo apt-get install nvidia-experimental-304
~$ sudo nvidia-xconfig
~$ sudo reboot

Tell me if your question (problem) solved.

Thanks

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Neil (goofandfroggie) said : #3

here is the output
  *-display
       description: VGA compatible controller
       product: G94 [GeForce 9600 GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:fa000000-fbffffff ioport:cc00(size=128) memory:fc000000-fc07ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux Beast 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19 10:26:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

But the first help worked but this may show the way it didn't work

Neil (goofandfroggie) said : #4

Thanks NikTh, that solved my question.