NVIDIA 5200m driver not working

Asked by Josh Crane on 2012-10-25

I am currently running a dell e6430 with a NVIDIA 5200m card in it running ubuntu 12.10. I have been trying to install the driver for this card with 12.04 and even xubuntu and have been unsucessful. when looking at nvidia-settings it states that I am not using the nvidia x-driver and to install the nvidia-xconfig file in order for this function to work. This also does nothing.

I have tried installing this card through apt-get install nvidia-current nvidia-settings as well as
 trying to add the repository sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
 and this fails to update as it cant find the correct update for the repository
I also tried downloading the official driver off of NVIDIA's web page. Everytime I install this driver my screen defaults to 640x480 and I cannot get it back to display the full screen. My screen also goes to 640x480 if I try installing the xconfig file.

One user suggested "sudo apt-get install linux-source) and headers (sudo apt-get install linux-headers-generic) and these also did not work at all for installing this specific NVIDIA driver.

I am at a loss here for fixing this issue and praying to the Ubuntu gods that there is a fix out there somewhere!

Any help would be greatly appreciated or even a hint on what step to take next as I feel like I have ran out of options.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-26
Last query:
2012-10-26
Last reply:
2012-10-25
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

please see this answer :
https://answers.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+question/212219

An open bug(error) exists with the Nvidia driver and Ubuntu 12.10 .

Try to follow the instructions to re-install the driver properly.

Thanks

Can you please give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Josh Crane (psycholomo) said : #3

I tried the suggestion from NikTh, this did not solve my problem. It ended up going right back to 640x480 resolution. nvidia-settings states that I do not have the nvidia-xconfig file and when I create it it does not do anything.

my lshw log

*-display
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f5000000-f5ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f6000000-f607ffff
  *-display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:48 memory:f6400000-f67fffff memory:d0000000-dfffffff ioport:f000(size=64)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux josh 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii nvidia-current 304.51.really.304.43-0ubuntu1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 304.51-0ubuntu2 amd64 Tool for configuring the NVIDIA graphics driver

note this machine has 2 cards in it the intel 4000 and the nvidia graphics driver. the machine believes that it is only a vga compatible device and not the actual card in the system . .

Seems you have a switchable video chip. This is nothing but pain under Ubuntu (and other Linux variants) and I doubt you will get this working well, if at all. I have never seen a success story with this mess and it is best avoided if you intend to use anything but Windows. This link may help:
https://help.ubuntu.com/community/HybridGraphics

Kieran Boyce (kieran-boyce) said : #5

I'm having a similar problem to Josh. I'm running Ubuntu 12.10 on a Dell PowerEdge T410 - a small server that I'm using as a workstation. (I had some issues installing 12.04 with the RAID card, so I went with 12.10).

Out of the box, the T410 doesn't have a hardware graphics accelerator, so the screen refresh is slow but it was displaying at a reasonable resolution (1280 x ...). I've installed a GeForce GT610 graphics card and tried a number of different driver sources, either from Nvidia themselves (version 304.60) or earlier versions from the standard ubuntu ppa and from ubuntu-x-swat/x-updates.

At this stage, using the standard VGA port my screen displays at 640x480 and I don't have the left-hand-side launch bar. I'm getting no signal from the Nvidia card.

Any help or suggestions in fixing this would be very much appreciated.

kieran

Josh Crane (psycholomo) said : #6

Thanks for the info actionparsnip, this solved my question and I will have to look into this issue further until a fix comes a long.

Thanks

Josh Crane (psycholomo) said : #7

Thanks actionparsnip, that solved my question.