I have problems with nvidia driver on ubuntu 12.10 64bit

Asked by Carnalbeast on 2012-10-20

I have problems with nvidia driver and repos on ubuntu 12.10 64bit.

When i 'm in a 3d game and try to change resolution ingame the game exits.

I tried to install the proprietary drivers (tested) but after reboot couldn't login to ubuntu , it lower the resolution and when i try to login i got nothing but the desktop screen no dash no menus no nothing !!!!

 the output of:

sudo lshw -C display; lsb_release -a; uname -a

is the following:
  *-display
       description: VGA compatible controller
       product: G92 [GeForce GTS 250]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:18 memory:fa000000-faffffff memory:d0000000-dfffffff memory:f8000000-f9ffffff ioport:ef00(size=128) memory:fb000000-fb01ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux darkpc 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

__________________________________________________________________________

look what i got in the output of a 3d game exited while i tried to change resolution:

X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 150 (XFree86-VidModeExtension)
  Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
  Value in failed request: 0x25b
  Serial number of failed request: 497
  Current serial number in output stream: 499

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-20
Last reply:
2012-10-20

Try:

sudo apt-get --reinstall install dkms

Carnalbeast (carnalbeast) said : #2

No it doesn't work.
I have a cheap ati radeon hd graphics card but i'm sure that i will have the same either tearing or extremely low fps on ubuntu as i had on beta2 .

Ubuntu 12.10 simply don't work for me , the only good is that it seems to has better performance but i can't change resolution on games and when i exit a game the ubuntu desktop remains with the resolution of the game for example if the games runned on 800x600 and exit i will have the same resolution.

I don't know what is the problem my card is too old ? cause geforce gts 250 run any new game full res full quality many many fps , absolutely perfect. Maybe its time to move to windows cause it started giving to my nerves......

Can you help with this problem?

Provide an answer of your own, or ask Carnalbeast for more information if necessary.

To post a message you must log in.