I have problems with nvidia driver and repos on ubuntu 12.10 64bit

Asked by Carnalbeast

I have problems with nvidia driver and repos on ubuntu 12.10 64bit.
When i 'm in a 3d game and try to change resolution ingame the game exits.

I tried to install the proprietary drivers (tested) but after reboot couldn't login to ubuntu , it lower the resolution and when i try to login i got nothing but the desktop screen no dash no menus no nothing !!!!

I have problems with these repos

 http://extras.ubuntu.com/ubuntu/dists/quantal/Release.gpg Unable to connect to extras.ubuntu.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.

Revision history for this message
Carnalbeast (carnalbeast) said :

I removed nouveau and reinstalled nvidia driver then i saw the messages..........proprietary modules/drivers to be installed ubuntu should have kernel sources installed i've installed the sources and now it works with proprietary driver, now i'm gonna test the 3d games bug if its fixed or not...

Revision history for this message
actionparsnip (andrew-woodhead666) said :

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a


Revision history for this message
Carnalbeast (carnalbeast) said :

       description: VGA compatible controller
       product: G92 [GeForce GTS 250]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:18 memory:fa000000-faffffff memory:d0000000-dfffffff memory:f8000000-f9ffffff ioport:ef00(size=128) memory:fb000000-fb01ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux darkpc 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
Carnalbeast (carnalbeast) said :

I've installed the sources and be able to install the proprietary nvidia drivers but the problem remains,
look what i got in the output of a 3d game exited while i tried to change resolution:

X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 150 (XFree86-VidModeExtension)
  Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
  Value in failed request: 0x25b
  Serial number of failed request: 497
  Current serial number in output stream: 499

Can you help with this problem?

Provide an answer of your own, or ask Carnalbeast for more information if necessary.

To post a message you must log in.