My GUI in Ubuntu fails to load randomly

Asked by Daniel Webster on 2012-09-29

When I boot my PC, Ubuntu will randomly boot to a command line or show an error message that it is rinning in low graphics mode.

When this happens, I log in through the command line with my username and password,

then Ubuntu will boot to a blank desktop. After some time it will ask me to enter the keyring password.

I then open a terminal with the ctrl+Alt+T shortcut and issue the "unity --reset" command.

This does start Unity, however the terminal output never completes, so I close the terminal.

This behaviour is completely random and once it happens it usually does it for the next few boots and then it will often boot normally for a while after that.

I am using Ubuntu 12.04 LTS and have NVIDIA graphics. However this same behaviour has occurred on previous versions of Ubuntu.

Is there a way I can fix this issue? I am happy to provide logs or any other information needed, however I am a semi newbie to Linux so clear instructions are helpful.

When Ubuntu boots into low graphics mode, it takes sometime before I can use the OS as the login process takes much longer.

Any help would be greatly appreciated.

Cheers,
Daniel

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-06
Last query:
2012-10-06
Last reply:
2012-09-30

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Does the system have a make and model?

Daniel Webster (spider-dan) said : #2

My laptop is an ASUS M60J http://www.asus.com/Notebooks/Multimedia_Entertainment/M60J/#specifications

the output of "sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia" is:

daniel@daniel-M60J:~$ sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia
[sudo] password for daniel:
  *-display
       description: VGA compatible controller
       product: GT216 [GeForce GT 240M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:d000(size=128) memory:d3000000-d307ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux daniel-M60J 3.2.0-31-generic-pae #50-Ubuntu SMP Fri Sep 7 16:39:45 UTC 2012 i686 i686 i386 GNU/Linux
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
ii nvidia-current 295.40-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-current-updates 295.49-0ubuntu0.2 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
ii nvidia-settings-updates 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
daniel@daniel-M60J:~$

Thanks for your assistance

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get --purge remove nvidia-current nvidia-current-updates nvidia-settings nvidia-settings-updates
sudo apt-get install nvidia-current

Gives you a later driver, will probably help

Daniel Webster (spider-dan) said : #4

Thanks Andrew!

I haven't had any problems in the last week, so I think that has fixed it.

What is the best way to ensure the graphics drivers stay up-to-date?

I always presumed that they were updated automatically with the Ubuntu software updater.

Thanks again for your help, it is much appreciated!

Daniel

Daniel Webster (spider-dan) said : #5

Thanks actionparsnip, that solved my question.