nvidia update broke 12.04, not boots to a command prompt

Asked by Kathy on 2012-09-06

Since the last nvidia update my system will only boot to a command prompt.

What's the best way to update the correct version of the 173 driver so my system works again?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
Last query:
Last reply:
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#1

Hi ,

do you want to remove nvidia-current and install nvidia-173 ? is that so ?

If I understood correctly , then boot from Recovery Mode and click ROOT .

Then give bellow commands with order . (write them down to a paper or mobile photo)

++++++++++++++++++++++++++++++++++
mount -o rw,remount /
apt-get purge nvidia*
apt-get install ubuntu-desktop
rm /etc/X11/xorg.conf
apt-get install nvidia-173
reboot
++++++++++++++++++++++++++++++++++

Thanks

Revision history for this message
Kathy (kittykat) said :
#2

Hi,

Thank you for the response. Sorry for my poor English. I am burned out from troubleshooting.

The current version of the Nvidia driver installed is 173.14.35 (from the log). I don't know the complete version number of the driver that worked.

I've checked the nvidia website but I couldn't find the correct driver or at least a history of drivers.

How do I figure out and then find the version of the Nvidia driver that worked?

thanks...

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#3

Ok ,

please open a terminal and give the results of bellow commands

+++++++++++++++++++++++++++++++
dpkg -l | grep nvidia

lspci -nnk | grep -iA2 vga
+++++++++++++++++++++++++++++++

If you don't have a Desktop Environment ( I see the title for Command Prompt boot) , then boot from recovery mode and select FailSafeX to login in low graphics mode.

Thanks

Revision history for this message
Kathy (kittykat) said :
#4

I have a live disk in since I have no gui.

dpkg -l | grep nvidia

ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers

lspci -nnk | grep -iA2 vga
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96 [GeForce 9600M GS] [10de:0648] (rev a1)
 Subsystem: Acer Incorporated [ALI] Device [1025:015e]
 Kernel driver in use: nouveau

Thank you for your help.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#5

Hello ,

results from a LiveCD not help.

We must see the results from the installed system.

Please try to follow the troubleshooting in answer #1 .

BUT

 penultimate command (before reboot) replace it with this

++++++++++++++++++++++++++++
sudo apt-get install nvidia-current
++++++++++++++++++++++++++++

Thanks

Revision history for this message
Kathy (kittykat) said :
#6

ok...so you are saying:

mount -o rw,remount /
apt-get purge nvidia*
apt-get install ubuntu-desktop
rm /etc/X11/xorg.conf
apt-get install nvidia-173

dpkg -l | grep nvidia

lspci -nnk | grep -iA2 vga

penultimate command (before reboot) replace it with this

sudo apt-get install nvidia-current

reboot

Revision history for this message
Kathy (kittykat) said :
#7

or perhaps you mean this:

ok...so you are saying:

mount -o rw,remount /
apt-get purge nvidia*
apt-get install ubuntu-desktop
rm /etc/X11/xorg.conf
sudo apt-get install nvidia-current

dpkg -l | grep nvidia

lspci -nnk | grep -iA2 vga

reboot

Revision history for this message
Best N1ck 7h0m4d4k15 (nicktux) said :
#8

Hello , I mean

+++++++++++++++++++++++++++++++++
mount -o rw,remount /
apt-get purge nvidia*
apt-get install ubuntu-desktop
rm /etc/X11/xorg.conf
apt-get install nvidia-current
reboot
++++++++++++++++++++++++++++++++++

sudo not needed (my mistake) cuz in ROOT Recovery Mode , you are connected
as Root , so sudo is redundant.

Thanks

Revision history for this message
Kathy (kittykat) said :
#9

I had to resize my ubuntu hard drive partitions. I had a dual boot Vista/Ubuntu system and ran out of space for Ubuntu.

I backed up the Ubuntu partition. I used Gparted to allocate more space to Ubuntu and blew away the Vista stuff.

Then I followed your instructions and voila they system booted into the desktop, the display is beautiful.

Now the only problem is during boot it looks for the two partitions that I removed. There must be a table somewhere that need to edit to remove the old partition names.

Thank you for all of your help!!!

Revision history for this message
Kathy (kittykat) said :
#10

Thanks NikTh, that solved my question.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#11

Yes , you must CAREFULLY edit the file /etc/fstab

Please give the results of

+++++++++++++
cat /etc/fstab

sudo blkid
+++++++++++++

Thanks

Revision history for this message
Kathy (kittykat) said :
#12

I commented out the entries in fstab referencing the partitions I removed.
I also back up fstab before changing it.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda3 :
UUID=f973036e-d213-42fe-b658-218e46241eee / ext4 errors=remount-ro 0 1
#Entry for /dev/sda5 :
UUID=6769FD75747F98BD /media/<CommonStorage> ntfs-3g defaults,locale=en_US.utf8 0 0
#Entry for /dev/sda2 :
#UUID=7AE45774E457319D /media/ACER ntfs #defaults,nls=utf8,umask=0222 00
#Entry for /dev/sda1 :
#UUID=EC264C5F264C2D40 /media/PQSERVICE ntfs #defaults,nls=utf8,umask=0222 0 0

sudo blkid

/dev/sda3: UUID="f973036e-d213-42fe-b658-218e46241eee" TYPE="ext4"
/dev/sda5: UUID="6769FD75747F98BD" TYPE="ntfs"
/dev/sdb1: SEC_TYPE="msdos" UUID="3234-3239" TYPE="vfat"

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#13

2012/9/8 Kathy <email address hidden>

> Question #207892 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/207892
>
> Kathy posted a new comment:
> I commented out the entries in fstab referencing the partitions I removed.
> I also back up fstab before changing it.
>
> # /etc/fstab: static file system information.
> #
> # <file system> <mount point> <type> <options> <dump> <pass>
>
> proc /proc proc nodev,noexec,nosuid 0 0
> #Entry for /dev/sda3 :
> UUID=f973036e-d213-42fe-b658-218e46241eee / ext4
> errors=remount-ro 0 1
> #Entry for /dev/sda5 :
> UUID=6769FD75747F98BD /media/<CommonStorage> ntfs-3g
> defaults,locale=en_US.utf8 0 0
> #Entry for /dev/sda2 :
> #UUID=7AE45774E457319D /media/ACER ntfs
> #defaults,nls=utf8,umask=0222 00
> #Entry for /dev/sda1 :
> #UUID=EC264C5F264C2D40 /media/PQSERVICE ntfs
> #defaults,nls=utf8,umask=0222 0 0
>
> sudo blkid
>
> /dev/sda3: UUID="f973036e-d213-42fe-b658-218e46241eee" TYPE="ext4"
> /dev/sda5: UUID="6769FD75747F98BD" TYPE="ntfs"
> /dev/sdb1: SEC_TYPE="msdos" UUID="3234-3239" TYPE="vfat"
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Ok , you did a good job. I am glad.

Do you have any problem now ?

Only I can see is that you don't have swap memory partition. Search with
these terms in google "Swap memory add after install ubuntu" if you want to
add it , or open a new question if you cannot figure it out.

Also , i see this /dev/sdb1: SEC_TYPE="msdos" UUID="3234-3239" TYPE="vfat"
but i assume is Usb flash ?
Not necessary to add it premanet in fstab.

Thanks

Revision history for this message
Kathy (kittykat) said :
#14

You are correct on all counts, it is a USB flash drive, actually a USB mouse. I never added the swap partition after installing Ubuntu even though I always intended to do so.

I haven't tried to reboot to see if the changes to fstab are correct but will take them on faith.

Thanks for all your help.