Xorg crash 12.04

Asked by andi on 2012-09-01

i have recently reinstalled ubuntu 12.04 after formatting the hard disk on my laptop (i386, nvidia 8600M GS graphics) next to windows 7

now i often have ploblems booting the system to ubuntu. sometimes it doesn't work at all, sometimes i end up at a command line and if i manage to log in normally, a message appeared saying that ubuntu has encountered an internal error.
i used to ignore this up until now, but it really is annoying.

checking the details, it said:

executable path
  /usr/bin/Xorg
package
  xserver-xorg-core 2:1.11.4-0ubuntu10.7
problem type
  crash
title
  Xorg crashed with SIGSEGV
apportversion
 2.0.1-0ubuntu12
architecture
  i386
nonfree kernelmodules
  nvidia
package architecture
  i386
procCmdline
  /usr/bin/X :0-auth /var/run/lightdm/root/:0-nolisten tcp vt7 -novtswitch -background none
procenviron

procversionsignature
  Ubuntu 3.2.0-29.46-generic-pae 3.2.24
segv analysis
  Segfault happened at: 0xb7127b19: cmpw $0xb858,(%edx)
  PC (0xb7127b19) ok
  source "$0xb858" ok
  destination "(%edx)" (0xc0041021) not located in a known VMA region (needed writable region)!
SegvReason
 writing unknown VMA
Signal
  11
SourcePackage
  xorg-server
StacktraceAdressSignature
  /usr/bin/Xorg:11:i686:/lib/i386-linux-gnu/libgcc_s.so.1+15b19:/lib/i386-linux-gnu/libgcc_s.so.1+166e1:/lib/i386-linux-gnu/libc-2.15.so+100007:/usr/bin/Xorg+188627:/usr/bin/Xorg+18c3aa:/usr/lib/nvidia-current/xorg/nvidia_drv.so+63d3e
StacktraceTop
  ?? ()
  ?? () from /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
Tags
  precise ubuntu ubuntu
Uname
  Linux 3.2.0.-29-generic-pae i686
UnreportableReason
 Please work this issue through technical support channels first.
UpgradeStatus
  No upgrade log present (probably fresh install)

Has anyone got an idea how to fix this? windows is running just fine, but i prefer to use ubuntu.
Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Can you give the output of:

sudo lshw -C display; apt-cache policy nvidia-current; lsb_release -a

Thanks

Revision history for this message
andi (dr-nucleus) said :
#2

yes. here please:

  *-display
       Beschreibung: VGA compatible controller
       Produkt: G86 [GeForce 8600M GS]
       Hersteller: NVIDIA Corporation
       Physische ID: 0
       Bus-Informationen: pci@0000:01:00.0
       Version: a1
       Breite: 64 bits
       Uhr: 33MHz
       Fähigkeiten: pm msi pciexpress vga_controller bus_master cap_list rom
       Konfiguration: driver=nvidia latency=0
       Ressourcen: irq:16 memory:ce000000-ceffffff memory:d0000000-dfffffff memory:cc000000-cdffffff ioport:2000(Größe=128)
nvidia-current:
  Installiert: 295.40-0ubuntu1.1
  Kandidat: 295.40-0ubuntu1.1
  Versionstabelle:
 *** 295.40-0ubuntu1.1 0
        500 http://at.archive.ubuntu.com/ubuntu/ precise-updates/restricted i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/restricted i386 Packages
        100 /var/lib/dpkg/status
     295.40-0ubuntu1 0
        500 http://at.archive.ubuntu.com/ubuntu/ precise/restricted i386 Packages
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Try:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get ugrade

You may benefit from the newer driver. My 6150LE 512Mb needs this to play Urban Terror, the drivers in the official repos don't cut it for some reason.

Can you help with this problem?

Provide an answer of your own, or ask andi for more information if necessary.

To post a message you must log in.