Screen Flickering and Image Retention on 12.04

Asked by DK on 2012-08-21

Hi,

I'm using a Dell M4600 with an IPS screen with an NVIDIA Quadro 2000M graphics card. I am currently using Ubuntu 12.04 and have not used older versions of Ubuntu on this laptop.

The problem is that the screen randomly flickers and the windows leave "ghosts" or there is image retention of the windows after they have been closed or minimized, i.e., there are transparent windows on my wallpaper after I close the window (this happens regardless if the screen is flickering or not). This happens randomly and I do not know the cause of the issue (I'm guessing its an nvidia driver issue). An example is when I'm browsing the web and I'm scrolling down the webpage and it starts flickering. I've seen posts about the screen flickering but nothing about the window images being retained. The image retention stays for a while but slowly fades over time. However, when I restart the computer the images look like they're "burned" into the screen.

I would really like to solve this issue. Please let me know what additional information you would need. I've tried using the x86 and x64 versions and they both end up with the same issue.

I appreciate the help!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Have you tried Unity2d session?

Revision history for this message
DK (publet) said :
#2

No, I have not tried that. What is it and what do I need to do?

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Log off and select it from the login screen with the Ubuntu logo near your username. It uses metacity instead of compiz as the window manager

Revision history for this message
DK (publet) said :
#4

Just tried the Unity 2D session and the flickering and image retention still takes place...any other suggestions?

I've tried "sudo unity --reset" before and it gave me a few problems. I've tried adding the latest nvidia repository and updating, and a few other things that I forgot now. All those had no effects.

Revision history for this message
DK (publet) said :
#5

output of "sudo lshw -C display":

  *-display
       description: VGA compatible controller
       product: GF106 [Quadro 2000M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:de000000-dfffffff memory:d0000000-d7ffffff memory:d8000000-dbffffff ioport:7000(size=128) memory:e0000000-e007ffff

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#6

ok and the output of;

lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Revision history for this message
DK (publet) said :
#7

~$ lsb_release -a; uname -a; dpkg -l | grep nvidia

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux dk-precision-linux 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
ii nvidia-current 295.40-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-current-updates 295.49-0ubuntu0.2 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver
ii nvidia-settings-updates 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Revision history for this message
DK (publet) said :
#8

I should add that if the screen is flickering when I shut down from Ubuntu, the images carry over on the next startup, through grub and even through the windows OS. The flickering continues in windows and slowly subsides.

Revision history for this message
DK (publet) said :
#9

I'm still trying to fix this issue. Could it be possible that I need to fix or swap out the hardware?

Thanks for the help.

Revision history for this message
Launchpad Janitor (janitor) said :
#10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
DK (publet) said :
#11

Help please?....

Revision history for this message
verbotenj (verbotenj) said :
#12

I have the same problem.

At Dell, they try with new LCD, motherboard, graphic card no solution found in hardware. I also did't find any HP that have a problem with same configration i7-2820; quadro 2000m ; IPS lcd.

What should I think is there a problem in hardware or software beasue if I turn off ubuntu and run win 7. I expect that windows drivers take care for graphics, so I expect that lcd should not flicker any more.

Revision history for this message
Launchpad Janitor (janitor) said :
#13

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
DK (publet) said :
#14

Problem still not solved...

Revision history for this message
verbotenj (verbotenj) said :
#15
Revision history for this message
jezyk (d-krysz) said :
#16

I've the same problem with exactly same configuration. Symptoms are the same. Did you find solution for described problem?

Revision history for this message
jezyk (d-krysz) said :
#17

I've tested bumblebee drivers unfortunately without luck.
Yesterday I done update my computer in the BIOS area from A5 to A13. That No affected for problem. Today I'm going to Install latest driver from nvidia website (release 304.64 - 2012.11.06). They wrote that:
"Fixed a regression in backlight control functionality on some notebook configurations."
Maybe this is it what should resolve our issue.

Revision history for this message
DK (publet) said :
#18

Let me know how that goes jezyk. I reinstalled ubuntu and just never enabled the additional drivers, and currently I am having no flickering issues. However, whenever the laptop suspends, the screen stays black after waking and using the ctrl-alt-f2 and ctrl-alt-f7 switches does not fix the issue. Not quite sure how to fix this new problem.

Revision history for this message
jezyk (d-krysz) said :
#19

I've checked the latest version of the Nvidia drivers. Unfortunately nothing has changed. Flickering and Image Retention are remain in force.

Revision history for this message
DK (publet) said :
#20

Do any of you guys who have the same setup have an issue with waking the laptop from suspend?

Revision history for this message
verbotenj (verbotenj) said :
#21

Hi,

If you don't install additional drivers you use vesa drivers.
Try this

I have also found http://bumblebee-project.org/ a sort of solution, because I expect official drivers from Nvidia ...

After I install bumblebee drivers there is no flickering. NVIDIA SHOULD LEARN from those guys!!!!!

Ubuntu linux

Currently, you need to open your terminal and enter the commands below.

sudo add-apt-repository ppa:bumblebee/stable

If you are on Ubuntu 11.04 or older and want newer drivers (recommended) than the ones available in the official repos, run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update

To install Bumblebee using the proprietary nvidia driver:

sudo apt-get install bumblebee bumblebee-nvidia

Reboot or re-login. More help and information for Ubuntu can be found here.

Revision history for this message
jezyk (d-krysz) said :
#22

Hi verbotenj,
Your description is OK but not for all.
My configuration has been described below:

http://commweb-ps3.us.dell.com/support-forums/laptop/f/3519/t/19432775.aspx

It means that Optimus technology is not available for work stations.
What I should to do? Just wait for the correct driver.
Kind regards

Revision history for this message
jezyk (d-krysz) said :
#23

Hi DK,

Regarding to your question about suspending and black screen. On my workstation I've the same symptom.
Solution is to ctrl+alt+f1, login as your username and execute command

sudo /etc/init.d/lightdm restart

It is helpful when you don't want to do "hard shutdown". It has consequence of your x session and opened applications and windows. Everything is going to die ;-)

Revision history for this message
verbotenj (verbotenj) said :
#24

Hi, jezyk (d-krysz)

I can't see what is your description.

My answer is about flickering.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#25

You could try:

sudo nvidia-xconfig; gksudo gedit /etc/X11/xorg.conf

Check the refres options are what you expect. If you make any changes, reboot to test

Revision history for this message
jezyk (d-krysz) said :
#26

Hi verbotenj.
You're right.
I've described my problem not clearly enought.
I mean that your solution is not suitable for my laptop because IPS RGB LCD panel and NVIDIA aren't supported for Dell Optimus technology. It has impact on bumblebee drivers which is supports only in the Dell with Optimus technology.
In my configuration double graphic cards are not avaliable. I've only NVIDIA without Intel. Optimus technology option in BIOS is not avaliable for this particular model and default status is disable and invisible.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#27

https://help.ubuntu.com/community/HybridGraphics

I've never seen this technology work in Linux. Nvidia also stated they will not be supporting this outside Windows (but they did later join the Linux foundation). I suspect you will have a tonne of issues with this and it is best avoided altogether if you plan to use anything but Windows.

Revision history for this message
jezyk (d-krysz) said :
#28

Hi actionparsnip,
Regardinf to your post and my issue.
It is other problem, not connected to hybrid graphics card.
Why?
Because I have only one graphic card which is NVIDIA.
Evidently it is a problem with NVIDIA driver for single graphic card Quadro 2000.
I'm going to create ticket in the Dell or Nvidia support.
Let them work on it.
It's bug, not a problem with unsupported technology like Optimus and dual graphic card.

Kind regards,

Revision history for this message
verbotenj (verbotenj) said :
#29

Hi,

there is one ticket but they are avoiding the responsibility.
http://en.community.dell.com/support-forums/laptop/f/3518/p/19467133/20194307.aspx#20194307

Revision history for this message
verbotenj (verbotenj) said :
#30

Hi, jezyk (d-krysz)

As I understand you your configuration is same as mine
Dell m4600
Ips RGB LCD
Quadro 2000m with no Intel graphic card. Because you are not able to disable Optiums Technology in bios.

I run bumbleebee drivers with no flickering.

Revision history for this message
jezyk (d-krysz) said :
#31

Hi verbotenj ,
How you did it?
I've tried by using guide from your link and other websites.
It looks like installation has been completed succesfuly. But how to check if my ubuntu use them even if Optimus doesnt start and not working.
Optimus command doesn't work.

[ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ERROR]Could not connect to bumblebee daemon - is it running?
I'cant start them.
Could you send me your Xorg.conf?

I will be appreciate for your advices or any help.
Kind regrds,

Revision history for this message
DK (publet) said :
#32

jezyk,

Regarding the optimus and dual graphic card bug, I raised this question about a year ago to a Dell representative. According to him, the IPS technology requires a 10 bit display that only the nvidia can provide. The intel built-in graphic card is still there but does not support the 10 bit IPS. Therefore, the Nvidia Optimus is removed from the bios and cannot be used.

Hope this answers your question.

Revision history for this message
verbotenj (verbotenj) said :
#33

Hi,

I am not able to run optimus because I think I don't have dual graphic card inside (I did't understand that you wan't to run optimus). Also bios notify this because I am not able to disable or enable optimus. I had problem with flickering and screen sunburn under 12.04 LTS. I solve my flickering problem with following commands:

     1 sudo add-apt-repository ppa:bumblebee/stable
    2 sudo apt-get update
    3 sudo apt-get install bumblebee bumblebee-nvidia
    4 reboot
    5 glxspheres

As you write you can't use I am not able to run either. I get the following error too. [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ERROR]Could not connect to bumblebee daemon - is it running?
jezyk----"In my configuration double graphic cards are not avaliable. I've only NVIDIA without Intel. Optimus technology option in BIOS is not avaliable for this particular model and default status is disable and invisible."

Revision history for this message
jezyk (d-krysz) said :
#34

Hi guys,
Finally I've finished my story with NVIDIA.
I've used your guide verboten. It really works.
Small inconvenient, that is no possibility to start working with compiz (on my workstation), but flickering and black screen after suspend have gone.
I don't now why compiz doesn't work but it is connected with 3D support for UNITY.
When I've made the test I saw something like this:

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string: 2.1 Mesa 9.0

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: no

Maybe this VMWare is the problem.

Thanks for your help guys.
Kind regards

Revision history for this message
jezyk (d-krysz) said :
#35

Hi guys,
Unfortunately it is not the end.
But I've good news.
Flickering has gone.
My solution is:
Remove bumblebee drivers,
Install NVIDIA drivers 304.64
change parameters in the nvidia panel,
GPU 0 (Quadro 2000M)
      DFP-5-(LGD) ---> Controls tab
values:
Dithering : Enabled
Mode: Dynamic 2x2
Depth : 8 bpc
after that wait for a while just 5 min maybe and flickering doesn't apear.
Compiz works and special efects to.
I have to find out, how to save those values as default.
In the xorg.confI I didn't find this section.
I hope that my solution will becomes helful for you guys.
Kind regards.
jezyk

Revision history for this message
DK (publet) said :
#36

Thanks for the update jezyk, please update us if you find out how to set those values as default.

Revision history for this message
jezyk (d-krysz) said :
#37

This is horrible to find appropriate parameters and add them to appropriate places.
Fnaly:
1. xorg.conf
...
Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-5"
    Option "metamodes" "1920x1080_60 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    Option "FlatPanelProperties" "Dithering = Enabled, DitheringMode = Dynamic-2x2"
 EndSubSection
EndSection

Because I didn't find anywhere information about the declaration of the Dithering Depth parameter which is crucial, I've made very simple workaround.
I've added
/usr/bin/nvidia-settings -a [gpu:0]/DitheringDepth[DFP-5]=2
to
~/.profile
And finally it works for me,
I hope that's helpful for all users who have ordeal with Nvidia.

Revision history for this message
Giuliano Gattamorta (ggattamorta) said :
#38

I had the same problem but made this things:

If you start nvidia xserver setting and go to section GPU (quadro 2000) chose DFP-5 (LGD) then chose Controlsther

You have to put Dithering Disabled and your screen will work correctly.

But if you restart the pc the problem will come again

You have to create X configuration file with the parameter that put Dithering Disabled forever.

The file is /etc/X11/xorg.conf

here my file with the necessary option (Dithering disabled) :

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.33 (buildd@allspice) Fri Mar 30 15:25:24 UTC 2012

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "LGD"
    HorizSync 44.0 - 66.0
    VertRefresh 40.0 - 60.0
    Option "DPMS"
    # HorizSync source: edid, VertRefresh source: edid
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "FlatPanelProperties" "Dithering=Disabled"
    Option "TwinView" "0"
    Option "TwinViewXineramaInfoOrder" "DFP-5"
    Option "metamodes" "1920x1080_60 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    # generated from default
EndSection

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "Quadro 2000M"
    Option "NoLogo" "True"
EndSection

Best tegards

Revision history for this message
rasolama (rsena) said :
#39

Thanks Giuliano that worked for me

Can you help with this problem?

Provide an answer of your own, or ask DK for more information if necessary.

To post a message you must log in.