unity won't start with nouveau driver on notebook with GeForce Go 6100 and more than 2G of RAM

Asked by D. Hugh Redelmeier

I have an old notebook with an nVidia GeForce Go 6100 video controller. It works fine with Ubuntu 10.04 using the nv X video driver.

I've made a clean install of Ubuntu 12.04. It used the proprietary nVidia drivers and didn't work. I removed the nVidia drivers and tried the nouveau drivers. That didn't work. By using the kernel parameter "nomodeset", I forced the use of the VESA driver, and that works fine, but cannot use the native resolution of the display.

I've updated all packages to the current level, as of 2012 June 15. I'm trying the nouveau driver again.

1) lightdm appears to work correctly
2) unity just paints the background and nothing else seems to show up

dmesg and /var/log/Xorg.0.log have some suspicious entries:

in dmesg, lots of messages like this, and variants:
[drm] nouveau 0000:00:05.0: PFIFO_DMA_PUSHER - Ch 3 Get 0x01256038 Put 0x011c60b0 State 0x4ffe0004 (err: INVALID_MTHD) Push 0x00000000

In Xorg.0.log, this message:
[ 79.451] [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
[ 79.451]
[ 79.451] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7f03a3c65866]
[ 79.451] 1: /usr/bin/X (mieqEnqueue+0x263) [0x7f03a3c45f43]
[ 79.451] 2: /usr/bin/X (0x7f03a3add000+0x62934) [0x7f03a3b3f934]
[ 79.451] 3: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f039b6e2000+0x5d88) [0x7f039b6e7d88]
[ 79.451] 4: /usr/bin/X (0x7f03a3add000+0x8ae07) [0x7f03a3b67e07]
[ 79.451] 5: /usr/bin/X (0x7f03a3add000+0xb0d4a) [0x7f03a3b8dd4a]
[ 79.451] 6: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f03a2e03000+0xfcb0) [0x7f03a2e12cb0]
[ 79.452] 7: /lib/x86_64-linux-gnu/libc.so.6 (ioctl+0x7) [0x7f03a1d61d27]
[ 79.452] 8: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmIoctl+0x28) [0x7f03a02f41a8]
[ 79.452] 9: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmCommandWrite+0x1b) [0x7f03a02f649b]
[ 79.452] 10: /usr/lib/x86_64-linux-gnu/libdrm_nouveau.so.1 (0x7f039fca6000+0x2bd7) [0x7f039fca8bd7]
[ 79.452] 11: /usr/lib/x86_64-linux-gnu/libdrm_nouveau.so.1 (nouveau_bo_map_range+0x109) [0x7f039fca91f9]
[ 79.452] 12: /usr/lib/xorg/modules/drivers/nouveau_drv.so (0x7f039feac000+0xb15d) [0x7f039feb715d]
[ 79.452] 13: /usr/lib/xorg/modules/drivers/nouveau_drv.so (0x7f039feac000+0xb819) [0x7f039feb7819]
[ 79.452] 14: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2SwapBuffers+0x110) [0x7f03a00ed790]
[ 79.452] 15: /usr/lib/xorg/modules/extensions/libdri2.so (0x7f03a00eb000+0x37d3) [0x7f03a00ee7d3]
[ 79.452] 16: /usr/bin/X (0x7f03a3add000+0x4e7a1) [0x7f03a3b2b7a1]
[ 79.452] 17: /usr/bin/X (0x7f03a3add000+0x3d6aa) [0x7f03a3b1a6aa]
[ 79.452] 18: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7f03a1c9876d]
[ 79.452] 19: /usr/bin/X (0x7f03a3add000+0x3d99d) [0x7f03a3b1a99d]
[ 79.452] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
[ 79.452] [mi] mieq is *NOT* the cause. It is a victim.
[ 80.610] [mi] EQ overflow continuing. 100 events have been dropped.

Question information

English Edit question
Ubuntu xserver-xorg-video-nv Edit question
No assignee Edit question
Solved by:
D. Hugh Redelmeier
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Tried Unity2d session?

Revision history for this message
D. Hugh Redelmeier (hugh-mimosa) said :


Thanks for looking at this.

How does one try a Unity2d session?

It sure looks as if this is the nouveau bug reported here: https://bugs.freedesktop.org/show_bug.cgi?id=46557
I've added my observations.

I find that the Unity desktop starts fine if I add "mem=2g" to the kernel parameters (in grub).

I was helped by xexaxo in freenode's #nouveau IRC channel.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

At the login screen, click the Ubuntu logo near your username and select the session there, then log in.

Revision history for this message
D. Hugh Redelmeier (hugh-mimosa) said :

Thanks Andrew.

I've decided to go with the mem=2g solution because it is likely some application will trigger the same problem the video controller, even if it isn't unity.

Revision history for this message
D. Hugh Redelmeier (hugh-mimosa) said :

Why did this get categorized as "xserver-xorg-video-nv" when the server in question is nouveau, not nv?