console mode impossible to reach

Asked by vigilian on 2012-05-18

Since I ve installed the nvidia current or even if I try to install the nvidia drivers manually, I can reach the console mode anymore ... All I can get is a graphical problem ä line of color"

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

hold shift at boot and select recovery mode then select root. you now have a console. if you want a terminal on the desktop, press CTRL+ALT+T

Revision history for this message
vigilian (vigilian) said :
#2

Okey i get that of course but do you mean that thé console mode Ctrl+alt+F1 And the other F functiOn doesn't work anymore? Because that what I mean when I say console mode, for me the recovery mode is not the same Than the console mode ( the network is not up, the drives neither...).
And if you have a problem with the Xserver you won't be able to access to a terminal So it's best to Consider the impossibility to access to the console mode as a bug!

Revision history for this message
vigilian (vigilian) said :
#3

Or at least a problem with a configuration file at least

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#4

Well that is a console mode isn't it. If you meant access to TTY1 etc from the desktop then why didn't you say that? It's vastly clearer.....

Which nvidia chip do you use?

Revision history for this message
vigilian (vigilian) said :
#5

Ow sorry, it was a misunderstanding then. Since the french documentation about this mode precise the word console mode it was making sense. I was thinking that TTy was just the technical denomination for the virtual peripheral.

My configuration is asrock z68 i2600k And the active graphic card is a 480 GTX

Do you think that this mode Consider the hd3000 as active And So primary?

Revision history for this message
vigilian (vigilian) said :
#6

I could add that the game eve online works as intended with crossover So the graphics accélération works.

Revision history for this message
Aaron O'Neil (alienoar) said :
#7

I am experiencing this same problem with Ubuntu 12.04, stable kernel 3.3.6, and NVIDIA driver 295.49 with GPU NVIDIA GeForce 8400GS. I arrived at this configuration as a result of instability caused by the stock 12.04 installation. I first had to install NVIDIA 302.07 beta driver after I experienced crippling repeated compiz crashes (was initially running onboard GeForce 7025/nForce 630a but since upgraded to the GeForce 8400GS). The 302.07 beta driver appeared to fix the compiz crash, as it appeared to be a bug in the NVIDIA 295.40 driver that was the cause. However, about a week ago after performing recommended Ubuntu software updates including a kernel upgrade, I started having multiple applications crashing in sequence and frequent system freezes where nothing was responsive and a hard boot was required. I upgraded to kernel 3.3.6 tonight after reding some forum posts of others having similar problems, and this wiped out my NVIDIA 302.07 driver and defaulted to the VESA driver at lower screen resolution (I have a 1920x1080 LCD monitor). I was able to install nvidia-current which is now version 295.49, however I cannot see my text terminals when entering from desktop with Ctrl-Alt-F1 etc. (only enters black screen with a thin magenta bar across the top of the screen as described above), and I cannot enter grub by holding Shift at startup. I have tried purging and reinstalling grub, I have tried editing grub config to manually set screen resolution, all to no avail. I would like to reinstall the 302.07 beta driver and build a kernel module for this kernel, but it appears I have no way to enter Recovery mode or text terminal to turn off lightdm and run the NVIDIA installer. Any help fixing the grub screen resolution so that text terminal is visible would be greatly appreciated.

Revision history for this message
Aaron O'Neil (alienoar) said :
#8

sorry I accidentally clicked "Propose Answer" when I meant to "Just Add a Comment"

Can you help with this problem?

Provide an answer of your own, or ask vigilian for more information if necessary.

To post a message you must log in.