Lost video driver after upgrading kernel

Asked by William Pabon on 2012-05-01

After doing the kernel update from 3.0.0-17 to -19 my video reverted to the default video driver. On the other hand, when I check the proprietary hardware drivers for my video (System > Administration > Hardware drivers) it says that the proprietary driver for my video is currently in use! My OS is 10.04 LTS. How do I solve this? Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Wyatt Smith
Solved:
Last query:
Last reply:
Revision history for this message
Miha Gašperšič (miha.gaspersic) said :
#1

Hello William,

I have run into the same problem as you asking here. Problem becomes because you update your kernel, and video driver didn't reconfigure correct or it just didn't do it yet. I have removed drivers but, problem has still persist on os and I couldn't do anything unless reinstall computer. There is problem with newest nvidia drivers and some amd's and because of this this error acoures. You will have to wait for a while untill fixes will be avalible.

I suggest you, that you backup importaint data and make reinstall of ubuntu and use default video drivers, because if you not use defaults you will always run into this problem when you update kernel. But with default drivers you can update kernel smooth and everything works well.

I have spend days in searching for equal problem and I didn't found any better solution so this is it what can i be able to suggest you.

Hope this helps you in some way.

Regards,
Miha

Revision history for this message
Best Wyatt Smith (wyatt-smith) said :
#2

The video driver module must be compiled against the new kernel. In order to do this you must have the headers installed for the current kernel. Sometime during normal updates the header packages are held back. You can manually install the header via Synaptic Package Manager. Do a quick search in Synaptic for linux-headers and install the headers for your updated kernel. After the headers are installed, re-install you video drivers.

Hope this helps

Revision history for this message
William Pabon (williepabon) said :
#3

Wyatt:
You were right. the Linux headers were not installed during the normal updates. But, in order to have my OS to recognize the Nvidia drivers, I went through the following steps:

1. Install the headers
2. Restart: the machine went into low graphics mode
3. Remove my Nvidia drivers (System > Administrator > Hardware drivers > Remove)
4. Restart: the machine went into default driver
5. Activate my Nvidia drivers (System > Administration > Hardware drivers > Activate) since I already had it in my system
6. Restart:

Now, I suppose, the driver is compiled against the newest kernel, and the Nvidia X Server shows the correct driver. Thanks for the help.

Revision history for this message
William Pabon (williepabon) said :
#4

Thanks Wyatt Smith, that solved my question.