Brightness controls do not work 12.04

Asked by znorris on 2012-05-01

Brightness controls do not change screen brightness. Applet appears, however this does not change the actual screen. This was tried using Kern 3.2.0-24-generic amd64.

Tried Mainline Kernel 3.3-rc7. Still does not work.

Dell Studio 1596.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Miha Gašperšič
Solved:
Last query:
Last reply:
Revision history for this message
Miha Gašperšič (miha.gaspersic) said :
#1

Hi Znorris,

First, see this( http://askubuntu.com/questions/57236/unable-to-change-brightness-in-a-lenovo-laptop/57610#57610 ) for instructions on changing brightness through the command line. If that doesn't work, it is likely a problem with your graphics driver and/or kernel version.

Note that by switching graphics driver, you can solve one problem but cause another. The default for nvidia has no power management, so people may switch to the proprietary driver if battery life on a laptop is important to them, but nvidia's drivers (being closed source) may not play nice with Ubuntu (leading to display issues like tearing in video).

If you want the nvidia driver, type in the terminal sudo apt-get install nvidia-current. After installing the driver, you'll need to enable brightness controls in /etc/X11/xorg.conf.

In /etc/X11/xorg.conf you should put:
Section "Device"
    Identifier "NVIDIA GeForce"
    Driver "nvidia"
    Option "NoLogo" "True"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

"Identifier" is not so important unless you have other stuff referring to this device in your conf file. You can replace with more appropriate name if it's not an Nvidia GeForce type card. Everything else must be as written; "NoLogo" is to avoid the annoying Nvidia splash screen.

To edit the file using a GUI text editor, type gksudo gedit /etc/X11/xorg.conf in the terminal. Save changes and reboot... if all went well, you will now be using the new driver and brightness controls will work! If it doesn't work, you can check if you're using the new driver by typing in the terminal lspci -v | grep -i -A 15 vga. You should get something like:

02:00.0 VGA compatible controller: NVIDIA Corporation Device 08a3 (rev a2) (prog-if 00 [VGA controller])
[some lines omitted....]
Kernel driver in use: nvidia
Kernel modules: nvidia_current, nouveau, nvidiafb

Kernel drive in use should be nvidia, not nouveau.

If that solve your question, please mark it as solved.

Regards,
Miha

Revision history for this message
znorris (znorris) said :
#2

Miha,

Thanks. It works by changing /sys/class/backlight/intel_backlight/device/intel_backlight/brightness

Is it possible to change the brightness applet to use this?

Revision history for this message
Miha Gašperšič (miha.gaspersic) said :
#3

I am not sure if you can do. Please provide us more informations about which applet do you talking about. Then I might answer your second question. But I am almost prety sure, that you can to in defaults Ubuntu's configuration manager to change this settings.

Regards,
Miha

Revision history for this message
znorris (znorris) said :
#4

I'm utilizing the default unity applet. The one that appears when I press a brightness key on my keyboard. I hope that makes sense.

Thanks for all your help,
Zach

Revision history for this message
Best Miha Gašperšič (miha.gaspersic) said :
#5

That sounds to me that you might have some issues with keyboard shortcuts. I think, that if all controls should get right you must have to use your's keyboard shortcut. I am preaty sure, that you have problems with proper drivers for your keys.

If you have driver problem, then this might solve your problem: http://ubuntuforums.org/showpost.php?p=11846307&postcount=44

Regards,
Miha

Revision history for this message
znorris (znorris) said :
#6

I'm sorry I don't think I was very clear.

1. Press keyboard shortcut for brightness down
2. Unity applet appears, shows the brightness decreasing
3. Physical screen does NOT change
4. Use the terminal method you pointed out
5. Physical screen does change brightness

How can I make the applet change the screen brightness so I don't have to do this via a term?

Revision history for this message
Miha Gašperšič (miha.gaspersic) said :
#7

I understand you what you want to say and my answer was, that this isn't os problem. I am sure, that this is driver problem for your keaboard shortcuts, because your computer doesn't know what he can do on pressing on this button. Try to search on internet for proper driver and install it and then it might work ok.

Because you can sucsesfull change brightness from terminal that's for sure problem with drivers or keyboard shortcuts.

Regards
Miha

Revision history for this message
znorris (znorris) said :
#8

Thanks for dumbing that down for me. I'm going to make this as solved!

Cheers,
Zach

Revision history for this message
znorris (znorris) said :
#9

Thanks Miha Gašperšič, that solved my question.