Cannot install Nvidia drivers 12.04

Asked by Jose Gonzalez on 2012-04-26

I have an ASUS X53S that comes with Nvidia GT540M.
Basically I can't run Unity3D because the drivers are not installed.
When i click on Additional Drivers in System Settings it says: No proprietary drivers are in use on this system.
I'm quite new with linux just started using it 4 months ago. I tried installing the Nvidia drivers from the software centre, but when i restart the X-server I get very poor resolution. Is someone having similar problems or know how to solve this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Jose Gonzalez
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Revision history for this message
Tristan Cormier (tristanc) said :
#2

Try uninstalling your current Nvidia drivers and install the proprietary ones found here: http://www.nvidia.com/object/linux-display-ia32-295.40-driver.html (32-bit)
I have guessed by your hardware that you need 32-bit drivers, but if you want to download the 64-bit ones, click on this link: http://www.nvidia.com/object/linux-display-amd64-295.40-driver.html

This should normally fix the problem for you, but in any way, please let me know how it works out if you can.

Revision history for this message
Jose Gonzalez (pepe-goniba-h) said :
#3

Hey I should have mentioned before that I had tried that before with no results. I get the low resolution after isntalling and restarting x-server.
This is the output after running sudo lshw -C display; lsb_release -a; uname -a:

 *-display
       description: VGA compatible controller
       product: GF108 [GeForce GT 540M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:db000000-dbffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:d000(size=128) memory:dc000000-dc07ffff
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:52 memory:dc400000-dc7fffff memory:b0000000-bfffffff ioport:e000(size=64)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux firith-ubuntu 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#4

Yeah I thought it'd be a dual GPU monstrosity. This causes no end of hell in Linux. There is a project called ironhide to support it as Nvidia have said they will not be supporting the technology outside of windows.

Revision history for this message
Jose Gonzalez (pepe-goniba-h) said :
#5

Well that is rather annoying since ironhide is not supported in 12.04 according to what i have been reading.
Still trying to figure this out....

Revision history for this message
Jose Gonzalez (pepe-goniba-h) said :
#6

Installed bumblebee and its fixed, I can use unity3d now, just in case anyone else has the same problem.