NVIDIA Card Problems

Asked by Sk1Special on 2012-04-25

EDIT: running 12.04 lts btw.
EDIT 2 :Forgot to mention. Ive only used windows till a day ago. So please provide detailed answers :]

Okay. I have a Intel core 2 Duo PC with a interal 80 GB SATA HDD and a Interal PATA 40 GB HDD, 4GB of RAM and a Dual Monitor Setup via HDMI/VGA Out put on
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
 Subsystem: eVga.com. Corp. Device 1311
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at b2000000 (32-bit, non-prefetchable) [size=16M]
 Memory at a0000000 (64-bit, prefetchable) [size=256M]
 Memory at b0000000 (64-bit, prefetchable) [size=32M]
 I/O ports at b000 [size=128]
 Expansion ROM at b3000000 [disabled] [size=512K]
 Capabilities: <access denied>
 Kernel driver in use: nouveau
 Kernel modules: nouveau, nvidiafb.

Now the problem with the current setup is that when i login the Ubuntu Load screen ( Not the password prompt but the like bios looking screen ) Just shows as a bunch of horizontal lines. , and theres no 3d capability .

 So i tried updating Via the *Additional Drivers* Icon..and it shows two different ones. One thats *recommended* and one that says * post release updates* both work. both fix the load screen. both let me choose all kindve options for my graphics card. EXCEPT Dual Monitors. when turned on the second monitor ju8st shows as a grey blank screen that i can not do anything with. ( except move my mouse onto and it changes the mouse into a x and doesnt let me click anything... )Also the second monitor does not show up under system settings -> displays.

So i tried installing the.. i believe its driver 295? whatever the current one is for here, that someone showd me how to do..and that disabled my resolution choices from the current 1440x900 TO 1024x720 or 800x600 AND will not let the system recognize my second monitor.

So my question is. How do i get the 3d capablities of my graphics card, Get my load screen to show up properly, Have the correct resolution settings for my monitors ( Being hdmi to view sonic 1440x900 and vga to sharp lcd tv vga in 1024x720 ) and have them both actually on and working all at once :]

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Sk1Special
Solved:
Last query:
Last reply:
Revision history for this message
Sk1Special (rpr21fl) said :
#1

okay. with some help from gaelfx in chat..got this sorted out. what basically happen was i had to reinstall /restart the *recommended * driver in additional drivers. then go into the nvidia control panel enable the second monitor. save to x config file. reset that file twice. so that the second monitor wasnt showing..then reenable it. which i guess thru defaults over layed its position ontop of the first screen..drag and drop to the side. ( so that it shows as one extended screen instead of two independant screens with a extended prjoection ) . and save everything and restart.. serious issues lol. but it all works now ( just installed the matrix 3d screen saver to test ) win win.