nvidia driver problems

Asked by John Hughes on 2011-07-09

Hi

I have just installed Ubuntu 11.04 on my computer and I would like to adjust the screen resolution. I have a 27" Asus Monitor that Windows was set to 1920 x 1200 resolution. I would like to have the same running on Ubuntu. At the moment it doesn't recognise the monitor and sets the resolution at 1024 x 728(4.3).

I installed Ubuntu on a system that at the moment is using the onboard video. The board is a Gigabyte GA-M61PME-S2P.

I have looked at System Settings > Additional Drivers where I installed NVidia Accelerated Graphics driver, but it it tells me it is activated but not in use.

If someone could advise me on how to change that to being used, that would probably help my problem.

Hope for help.

Regards

John

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-09
Last reply:
2011-07-10
wojox (wojox) said : #1

Try from the terminal:

sudo nvidia-xconfig

gksudo nvidia-settings

Can you also give the output of:

sudo lshw -C display; lsb_release -a; dpkg -l | grep nvidia

Thanks

John Hughes (sarian90) said : #3

  *-display
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: nVidia Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:23 memory:f8000000-f8ffffff memory:e0000000-efffffff memory:f9000000-f9ffffff memory:fa000000-fa01ffff
lsb_release-a: command not found
dpkg-1: command not found

Raymond Trim (raytrim83) said : #4

John I have the same problem. I think you did not input the info request from actionparsnip correctly. Do it by copy and paste when it should go correctly. I have also followed the advice form wojox, concluding with removing and reinstalling the driver but the problem still persists. My output from actionparsnip request is

 *-display
       description: VGA compatible controller
       product: GT218 [GeForce 210]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fd000000-fdffffff memory:e0000000-efffffff memory:de000000-dfffffff ioport:dc00(size=128) memory:fea00000-fea7ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
ii nvidia-common 0.2.30 Find obsolete NVIDIA drivers
ii nvidia-current 270.41.06-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 270.29-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Actionparsnip or Wojox : Could you please advise on the next step. Thank you

@Raymond Trim please don't append your result on a other user question this may generate a confused thread please open your own question then you can add your new question link here if you solve your issue

If you run:

sudo nvidia-xconfig; gksudo nvidia-settings; gksudo gedit /etc/X11/xorg.conf

Set the resolution to something, then click "Save to X config" then close the app. Gedit will then open, find the resolution and change it to what you desire then reboot. Should be ok.

John Hughes (sarian90) said : #7

Hi

I have tried these suggestions but I think the problem seems to be the onboard video. My son tried Ubuntu on his computer and the result was great, the resolution was at its best. With the modifications I have made, the resolution has been made worse. I'm off to get a video card and see if that makes a difference.

Regards

John

John Hughes (sarian90) said : #8

Hi

I haven't gone to get the video card yet but the following is with the onboard video.

I re ran the previous command I was asked for and this is the result. A bit better.

john@LinuxPC:~$ sudo lshw -C display; lsb_release -a; dpkg -l | grep nvidia
[sudo] password for john:
  *-display
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: nVidia Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:22 memory:f8000000-f8ffffff memory:e0000000-efffffff memory:f9000000-f9ffffff memory:fa000000-fa01ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
ii nvidia-common 0.2.30 Find obsolete NVIDIA drivers
ii nvidia-current 270.41.06-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 270.29-0ubuntu1 Tool of configuring the NVIDIA graphics driver
john@LinuxPC:~$

Hope that may help.

Regards

John

Can you help with this problem?

Provide an answer of your own, or ask John Hughes for more information if necessary.

To post a message you must log in.