Mouse pointer points in a place other than the tip of the pointer. Also, screen is tiled.

Asked by Devin

Ubuntu 10.10

I Printed Screen to show what I'm talking about while the problem is ongoing. But, I opened the picture and it looked normal instead even while the problem was ongoing. Whenever I boot up the computer it is like this or after I fix it and then the screen saver starts it reverts back to the problem. The power management does not cause this problem. The problem was there from the start: during the installation. I can fix it temporarily by applying a different resolution and then reverting back to the resolution without saving the new applied resolution. This fixes both the pointer from pointing at the bottom of the pointer icon and the whole screen, even besides the background, from being tiled and cut off at the bottom the same distance that the pointer points problematically. The screen is also shifted to the left. The left part that is cut off is shown on the right side of the monitor. But the mouse does not show on the right side when I put it past the left side, only everything else. The cut off portion at the bottom does not come out the other side at the top, but the top menu bar is larger than normal and the Firefox icon has a blue streak emanating from the end of the blue portion of the Firefox logo straight to the top. If I enter Configure Display Settings again after it is fixed, it right away makes the problem again. I expect it to fit the screen without me having to, temporarily, fix it. I'm using a Dell monitor, model number: E172FPt.

Question information

English Edit question
Ubuntu xserver-xorg-video-nv Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :

Did you try auto-adjust
and verify resolution.

Which graphic card?
Open a terminal: ctrl+alt+t
sudo lshw -C video

## Highlight text in terminal and paste output it here with middle mouse click.

btw. it isn't possible to attach screenshots here on 'LP-answers', you need to upload it to your preferred web page and post link of image here.

Revision history for this message
Sam_ (and-sam) said :

You may need to add modelines to xorg.conf.
e.g. lets take what documentation says, virtual resolution is 1280 x 1024 60Hz (verify with xrandr) you would create the modeline with ctv:
cvt 1280 1024 60

Revision history for this message
Sam_ (and-sam) said :

... create the modeline with ctv
... create the modeline with cvt

Revision history for this message
Devin (8basepairs) said :

Yes, sorry I forgot to mention that I tried adjusting the screen with the buttons on the display. After doing that it just moves the screen to show rows or columns of nothing whichever way I move it, with the tiled screen still problematic. It auto adjusts automatically, so that didn't work either, and I'll speculate it wouldn't based on the manual movement changes not working.

Here is the information you asked for,

       description: VGA compatible controller
       product: NV18 [GeForce4 MX - nForce GPU]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a3
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-2.0 vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=64 maxlatency=1 mingnt=5
       resources: irq:16 memory:fc000000-fcffffff memory:ec000000-efffffff memory:f3500000-f357ffff memory:fda00000-fda1ffff

I'm upgrading to Ubuntu 11.04 now. I'll see if that will fix it. If so, I'll click Problem Solved.

Revision history for this message
Devin (8basepairs) said :

This is what happened after I entered cvt 1280 1024 60 into the Root Terminal,

# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

Revision history for this message
Devin (8basepairs) said :

I followed the instruction on the documentation and did the commands in the regular Terminal. With the output of my previous post I then entered xrandr --new mode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

The screen blanked out for a second and it came back up how it was before I entered the command and it went blank.

Revision history for this message
Sam_ (and-sam) said :
Revision history for this message
Devin (8basepairs) said :

After installing Ubuntu 11.04 it is worse. The one time, one second blank screen now happens every 30 seconds. Each time it resets the screen from my temporary fix to make the problem, now the temporary fix that used to last for as long as restarting the computer now lasts up to 30 seconds. It is sub temporary. I don't think nouveau will work for me, even if I knew how to install it, because the testing page you linked says someone with my graphics card tried it and the only feature was supported on the checklist was Boots. Also, more information that I think I should say is that Configure Display Settings says Monitor: Unknown.

Revision history for this message
Sam_ (and-sam) said :

> installing Ubuntu 11.04 it is worse

Which shell at the moment, Unity, Unity-2d, classic-desktop, in case change the option on login to classic-desktop or Unity 2D.

Try to switch driver.
## unity
To view all apps left click on this starter

## classic desktop
system administration -> additional drivers

Notes about switching drivers in case of problems.

Since you're now a happy user of Beta-1 maybe you'd like to help to make Ubuntu better and consider to report a bug.
CLI e.g.:
LANG=C ubuntu-bug nouveau

Revision history for this message
Devin (8basepairs) said :

I had already did the system administration -> additional drivers after I installed 11.04 and installed the one available. I think the shell was Unity. But, I am unable to change it to 2D or classic because the screen made an even worse problem after it failed the Suspend and Resume Test where the words are unreadable and the screen is jumbled and pixelated. Even after reboot. It looks like what I saw in the screensaver previews after I installed 11.04, but now it is for the whole desktop interface. I can't even boot up the computer anymore, because it is even worse than the just mentioned pixelation problem when it just shows columns of 2 alternating colors without even loading the desktop. I think I have to burn another DVD, this time for 11.04 instead of 10.10 and load classic-desktop right away? At least to get in into it for use, right now I'm using another computer. The monitor works fine still on Windows 7 with the other computer I'm using.

Revision history for this message
Devin (8basepairs) said :

Just got 11.04 burned on the slowest speed. Now, I've installed it. Still buggy, after I suspend and resume it makes those columns and was able to determine their color: thin Green lines with wide Black background strips. At least when I resumed, after restarting to get rid of the green lines in a blank screen, it didn't make the text unreadable.

Thanks for showing me where to change the Unity. I changed it to classic, no effects yet the problem still persists. Even the screen saver previews are still very choppy. Again, the screen saver was fine on 10.10. Both versions have the arrow selecting lower than its point and the bottom Panel cut off even if I change the vertical positioning buttons on the monitor. Plus part of the left side of the screen is on the right side of the monitor.

Revision history for this message
Sam_ (and-sam) said :

If possible attach a screenshot to bug report. Then, at the bottom, below the comment field, click on 'add attachment'.
Since you didn't file the bug via apport it's missing essential infos, you need to upload sys infos in order to provide developers as much info as possible to triage the bug.
Please use apport-collect now to upload those infos.
apport-collect 748768

Side note, to report via apport also triggers LP in case to find similar, already reported bugs. It's developed to better support triage.

Revision history for this message
Devin (8basepairs) said :

I posted a screenshot. I followed the instructions on to run Apport and it said it is already running.

After I did more of the system testing program my mouse doesn't move smoothly anymore and it drags the cursor even after I lift up the left button after clicking.

Revision history for this message
Devin (8basepairs) said :

I forgot to mention something about the mouse lag. It still does it after reboot.

Revision history for this message
Sam_ (and-sam) said :

Yep apport is installed, but in order to upload infos to an existing bug, you need to open a terminal: ctrl+alt+t
and type:
apport-collect 748768

Revision history for this message
Devin (8basepairs) said :

Thanks, man. I hope this helps them.

Revision history for this message
Devin (8basepairs) said :

This problem is solved. I installed Ubuntu 11.10 after migrating to another distribution for a while. It looks like a new driver solved it; for the name of the one that used to be on it when it didn't work I remember is different. This new driver's description even mentions support for Unity, which wasn't possible before. The one that fixed it is called NVIDIA accelerated graphics driver (version 96) [Recommended].