Can't see display at all!

Asked by gnsl5 on 2009-11-11

Hello, complete newbie here! I installed Ubuntu 9.10 on an older Dell system. The install went fine, but after the system rebooted to the desktop, all I get is massive lines accross the screen. I can barely see a couple of menu bars underneath the lines. I am using and older CRT monitor - BenQ V551 2003. I did try adjusting the settings using the monitor buttons, but it did nothing. Per the specs, the resolution should be 800x600. When I finally figured out how to get to a command line, I tried numerous strings, without success.

I tried the following:
xrandr - "can't open display" was the message returned.
sudo gedit /etc/X11/xorg.conf - "can't open display" message
xrandr --addmode S-video 800x600 - "can't open display" message

Do I need to try a command to get an updated driver? If so, what is the command?
This monitor had been working ok for both the Dell system w/ Windows Me, and a server running Windows 2000.

I have no idea what to try next, so any help that can be provided would be greatly appreciated! Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-30
Last reply:
2009-11-30
houstonbofh (leesharp) said : #1

This is where the video card, or your monitor are not correctly telling X what resolution your support. Based on this page http://www.firingsquad.com/hw/1972/BenQ_V551/ you can run 1024x768 at 67hz, but 800x600 at 85hz is recommend.

Failsafe X should support this. What video card do you have? If you do not know, type "lspci" from the command line.

gnsl5 (gnsl5) said : #2

houstonbofh,

I tried "lspci" from the command line, but don't really know what I'm looking for.
The video card is an Intel 3D AGP Graphics.
Can you tell me the exact phrasing I would need to use at the command prompt?
Not familiar enough with 'Failsafe X' yet to know how to enter correctly at the command line.
Thanks!

houstonbofh (leesharp) said : #3

The command "lspci" stands for LiStPCI, and it lists everything on the PIC bus. One line will look somewhat like this.

01:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7950 GT] (rev a1)

However, I doubt you will have a GeForce...

Now failsafe X is a nice idea, but like all good intentions... It is supposed to give you a usable screen when everything else fails. However, it usually gives you a unusable screen when things should work right, and ignores the setting you try to set. No I am not bitter...

So, give the output of "lspci" and "xrandr" so we know where we are.
Also install "dontzap" (sudo apt-get install dontzap) and run "sudo dontzap -d" so we can restart X quickly with ctl-alt-bksp.
And if you feel like it, try ctl-alt-bksp at the squiggle screen to see if an X restart (without a reboot) helps. On some Dells, it does.

gnsl5 (gnsl5) said : #4

Appreciate your help in trying to resolve this problem with the display.

I haven't had a chance yet to try your recent suggestions, but hope to soon.

When I do, hopefully it fixes the problem, and I'll be able to respond as
such on Launchpad!

Thanks again!

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
houstonbofh
Sent: Thursday, November 12, 2009 12:22 AM
To: <email address hidden>
Subject: Re: [Question #89714]: Can't see display at all!

Your question #89714 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/89714

houstonbofh proposed the following answer:
The command "lspci" stands for LiStPCI, and it lists everything on the
PIC bus. One line will look somewhat like this.

01:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7950
GT] (rev a1)

However, I doubt you will have a GeForce...

Now failsafe X is a nice idea, but like all good intentions... It is
supposed to give you a usable screen when everything else fails. However,
it usually gives you a unusable screen when things should work right, and
ignores the setting you try to set. No I am not bitter...

So, give the output of "lspci" and "xrandr" so we know where we are.
Also install "dontzap" (sudo apt-get install dontzap) and run "sudo dontzap
-d" so we can restart X quickly with ctl-alt-bksp.
And if you feel like it, try ctl-alt-bksp at the squiggle screen to see if
an X restart (without a reboot) helps. On some Dells, it does.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/89714/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/89714

You received this question notification because you are a direct
subscriber of the question.

gnsl5 (gnsl5) said : #5

hustonbofh,

Finally tried you suggestions, but had no luck!

1)output of "lspci" was:
00:01.0 VGA compatible controller: Intel Corporation 82810 (CGC) Chipset
Graphics Controller (rev 03)

Not sure how to input this info. Tried numerous commands and got nowhere!

2) output of "xrandr" was:
Can't open display"

3) output of "sudo apt-get install dontzap" was:
E: couldn't find package dontzap

4) ctl-alt-bksp at squiggle screen did nothing

Could I have input the commands incorrectly?
Is there another command to try?

Not sure what to try next, if anything!

Thanks,
gnsl5

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
houstonbofh
Sent: Thursday, November 12, 2009 12:22 AM
To: <email address hidden>
Subject: Re: [Question #89714]: Can't see display at all!

Your question #89714 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/89714

houstonbofh proposed the following answer:
The command "lspci" stands for LiStPCI, and it lists everything on the
PIC bus. One line will look somewhat like this.

01:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7950
GT] (rev a1)

However, I doubt you will have a GeForce...

Now failsafe X is a nice idea, but like all good intentions... It is
supposed to give you a usable screen when everything else fails. However,
it usually gives you a unusable screen when things should work right, and
ignores the setting you try to set. No I am not bitter...

So, give the output of "lspci" and "xrandr" so we know where we are.
Also install "dontzap" (sudo apt-get install dontzap) and run "sudo dontzap
-d" so we can restart X quickly with ctl-alt-bksp.
And if you feel like it, try ctl-alt-bksp at the squiggle screen to see if
an X restart (without a reboot) helps. On some Dells, it does.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/89714/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/89714

You received this question notification because you are a direct
subscriber of the question.

Please be sure your system is fully updated/upgraded... please try now...? you must be connected to the net

Open a Terminal from the menu Applications → Accessories → Terminal and type:

Suggestion: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...

(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a

then to update and upgrade and also check pending or missing packages, still using terminal type:

sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get autoremove

sudo apt-get install dontzap

and to restart your system please type:

sudo reboot

Hope this helps

houstonbofh (leesharp) said : #7

OK. We have some information.

First,
"00:01.0 VGA compatible controller: Intel Corporation 82810 (CGC) Chipset
Graphics Controller (rev 03)"
This means you have an "i810" graphics controller in PCI id 01. It is what I thought, and a slight pain in the backside.

The output of xrandr means that X is totally failing to start, so you must be in single user mode. Could you try from a live CD?

As to "dontzap" it seems they moved it again... Sigh... Sure makes things hard when they keep moving my tools. Fix is here, but only once gnome is up. https://wiki.edubuntu.org/X/Config/DontZap

Now, what I think is happening I have seen a few times on older Dell systems with i810 graphics. The Grub boot-loader goes into graphics mode, and when you come up and hand over graphics to X, the hand-off fails, and you crash. The fix I used to use was to set Grub to boot in text mode, and it solved the problem. But Karmic uses Grub2, and I do not know how to do that. Another option is to turn of GDM and boot into a fully text based machine. You would then have to type "startx" every time you logged in. A third option is to shove in a different graphics card, as it is only the Dell onboard graphics that have this problem.

Can you help with this problem?

Provide an answer of your own, or ask gnsl5 for more information if necessary.

To post a message you must log in.