Screen shifted to right after the last NVidia driver update

Asked by Thomas George on 2013-04-12

Soon after the auto updater updated the NVidia driver version from 295.40-0ubuntu1.3 to 304.88-0ubuntu0.0.2, my screen shifted to the right by about 1/2 an inch. There is blank space to the far left of the screen that I cannot move the mouse into, and I can move the mouse into the invisible area to the right of the screen, and click buttons etc.

The native resolution of the display is 1920x1080. If I change the resolution, the screen becomes normal (albeit with bad resolution). It reverts back to shifting right when I change the resolution back to 1920x1080. I have re-installed the diver multiple times to no avail.

This has happened to me in the past. Last time it happened was when I upgraded to Ubuntu 12.10. I just could not fix it, so I downgraded to 12.04, and the problem went away, if I used Ubuntu 2D. Now, even if I use Ubuntu 2D, I have this problem. This only started after this last update to the newer version of the driver. I have an AMD-64 system with Nvidia graphics card, and the nvidia-current driver.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

uname -a
Linux thomas-Desktop 3.2.0-40-generic #64-Ubuntu SMP Mon Mar 25 21:22:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Please help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas George
Solved:
2013-04-14
Last query:
2013-04-14
Last reply:
2013-04-13
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

please provide some more info in order to get help.

    lspci -nnk | grep -iA2 vga
    dpkg -l | grep -i nvidia
    /usr/lib/nux/unity_support_test -p

Regards
 NikTh

Thomas George (t-george78) said : #2

lspci -nnk | grep -iA2 vga
00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] [10de:03d0] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:2a58]
 Kernel driver in use: nvidia

dpkg -l | grep -i nvidia
ii nvidia-common 1:0.2.44.2 Find obsolete NVIDIA drivers
ii nvidia-current 304.88-0ubuntu0.0.2 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 304.88-0ubuntu0.0.2 Tool of configuring the NVIDIA graphics driver

/usr/lib/nux/unity_support_test -p
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6150SE nForce 430/integrated/SSE2
OpenGL version string: 2.1.2 NVIDIA 304.88

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Hope this helps resolve the issue.

N1ck 7h0m4d4k15 (nicktux) said : #3

Try to remove this driver and install nvidia-173-updates. I think it has better support on your "old" graphics card.

    sudo apt-get purge nvidia-*
    sudo rm /etc/X11/xorg.conf

Then

    sudo apt-get install nvidia-173-updates
    sudo nvidia-xconfig

Reboot your system and then open the nvidia-settings to fix the resolution.

Regards
 NikTh

Thomas George (t-george78) said : #4

That worked! Thank you NikTh!