Cannot use my Monitor with DisplayPort on 12.10: failed to train DP

Asked by Sebastian Schulze on 2013-01-04

Hi folks!

I'm having a bit of a strange problem here: I'm running Ubuntu on my MacBookAir5,1 and the only thing (!) thats causing troubles is the display:

If I connect to a Dell U2711 display via a DisplayPort cable, the internal and external monitor turn black and the whole system seems to hang. (I can't even switch back to the consoles). Using the same setup with a DisplayPort -> DVI-D adapter, both displays work fine. (Except that the monitor goes up to 1080p resolution then). I tried the standard 12.10 drivers and I've already tried the xorg-edgers ppa - both with the same effect.

Is there anyone around probably using the same setup (apple hardware) or some already reported issues I should have a look at?

Cheers,
 Sebastian

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Sebastian Schulze
Solved:
2013-01-04
Last query:
2013-01-04
Last reply:
2013-01-04

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks