Xserver won't load on 12.10 Secure LiveUSB

Asked by Christopher Welborn on 2012-12-28

I saw someone with a similar problem, unfortunately his fix didn't help me. This HP 2000-2b49WM Notebook PC can't boot Ubuntu 12.10 Secure from a CD (Fedora's new CD works but has other problems), I have to make the ISO into a LiveUSB for it to even try. The graphics aren't working, it's either completely black, kicked to console by Xorg error, or black for first half of the boot and very very dark tinted after it loads (so dark it almost looks black, but it is showing a shutdown dialog when I press the power button. you just have to look really hard in the right light). Here are some kernel options I've tried. I just want it to boot into Live mode, so I can make sure it works and then do the Install.

i915.modeset=0 : Nothing
xforcevesa : Nothing
i915.modeset=0 xforcevesa : Kicked to console by Xserver (No Screens Found)
acpi=off : Looks to boot normally, (best looking splash screen so far) but spews out "/init Line 7 /dev/sr0 no medium" over and over. ...I'm thinking this is because I have to use a LiveUSB and it's expecting a CD/DVD somewhere?
i915.blacklist=1: Kicked to console by Xserver (No Screens Found)
nomodeset : doesn't work

Using default settings with no special kernel options I was able to get a completely black screen on the first half of the boot, but then when I press the power button I can see a "Shutdown Dialog" with buttons & cursor. The thing is, the screen is so dark I have to put my eyeballs against the screen to read what the buttons say. I mean the whole thing is WAY too dark. Most people would dismiss it as a black screen, but I could actually see my mouse move over the buttons very very faintly if I look really close.

...trying to reconfigure Xorg when i DO get to a console tells me number of screens doesn't match. Also, with i915.blacklist=1 Xorg -configure tells me "Invalid Parameter" for inserting i915.ko module, and "Invalid value 1".

My machine has Windows 8 pre-installed on it (UEFI).
My video card is recognized by Linux as: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (says UNCLAIMED in lshw)
Machine is recognized as: HP 2000 Notebook PC

On a personal note, I love debian and ubuntu. I got this laptop so I could make it a linux machine, so this is very disappointing. I have 2 other machines that I run linux on, and i've never had these kind of problems (i've had problems, but they would at least boot so I could fix them)...anyone have any clues? The way dark screen gives me hope, like it just needs to be tweaked the right way. has anyone seen anything like this before?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Christopher Welborn
Solved:
2012-12-28
Last query:
2012-12-28
Last reply:
2012-12-28

According to
http://www.walmart.com/ip/HP-15.6-2000-2b49WM-Laptop-PC-with-AMD-E-300-Accelerated-Processor-and-Windows-8/21666192

It's using an AMD Radeon HD 6310, so why are you adding boot options for the Intel driver?

Did you also MD5 test the ISO you downloaded?

Thank you for your replies. I've tryed several distros and I only tested some of them. I'll md5 test this Ubuntu 12.10 Secure and post back.
@actionparsnip: you're looking at the wrong pc. Mine has a Pentium with integrated graphics chip (linux confirms), not AMD. I wish it was AMD with a radeon, I probably wouldn't have these problems. I looked up the exact model and specifications thru HP's tools and web site, there are several of these notebooks with different features. Mine is like this according to HP's site:

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03499318&tmp_task=prodinfoCategory&cc=us&dlc=en&lc=en&os=4132&product=5309518&sw_lang=

           Product Number: C2M44UA
             Microprocessor: 2.20GHz Intel Pentium Processor B960
Microprocessor Cache: 2MB L3 Cache
                           Memory: 4GB DDR3 SDRAM (1 DIMM)
                  Memory Max: Maximum supported = 8GB
                 Memory Slots: 2 user accessible
               Video Graphics: Intel HD graphics with up to 1696MB total graphics memory
                                                (Linux says: Intel Corporation 2nd Generation Integrated Chip (rev 09))
                              Display: 15.6-inch diagonal HD BrightView LED-backlit display (1366x768)
                        Hard Drive: 500GB 5400RPM hard drive
           Multimedia Drive: SuperMulti DVD Burner
                  Network Card: 10/100BASE-T Ethernet LAN (RJ-45 connector)
   Wireless Connectivity: 802.11b/g/n WLAN
                                 Sound: Altec Lansing dual speakers
                           Keyboard: Full-size keyboard
               Pointing Device: Touchpad supporting multi-touch gestures with on/off button
                  External Ports: Multi-Format Digital Media Card Reader for Secure Digital cards and Multimedia cards
                                               3 Universal Serial Bus (USB) 2.0, 1 HDMI, 1 VGA (15-pin), 1 RJ-45 (LAN), 1 Headphone-out, 1 Microphone-in

                       Dimensions: 14.80 in (W) x 9.72 in (D) x 1.20 in (min H)/ 1.41 in (max H)
                                Weight: 5.39 lb
                                  Power: 65W AC adapter
                                                6-cell 47WHr 2.2 Ah lithium-ion battery
       ID Mech Description: HP TrueVision HD Webcam with integrated digital microphone

...this is after using HP's lookup tool, and linux confirms the information using 'lspci', and 'lshw'. I'm convinced its an Xorg driver/config problem. I just don't know what to do next because dpkg-reconfigure doesn't work, Xorg -configure detects too many screens (this laptop has 1 screen, 1 HDMI port out, and 1 VGA out, but Xorg detects 4 screens and alot of other 'extra stuff'). The guy with the previous post has the same chip, and was able to fix his using the kernel options. I don't know why it's not working for me. I'm gonna md5 test because I can't remember if I tested this distro yet. Is it just too new? I didn't think it was that new, I think they just slapped Windows 8 on an older model. Thanks for your help,

-Cj

MD5 Check Successful: 9c7a4995811b98dfd503fe67ae5c928a

...from http://sourceforge.net/projects/ubuntu-secured/files/

Update: Still not solved, but I was able to boot into the LiveDVD using BOTH a LiveUSB AND LiveDVD at the same time with acpi=off set. The LiveUSB allows it to boot, then files are being read from LiveDVD. acpi=off is not what I want though, I will do some more research. I'm getting closer, a couple days ago I didn't have anything at all, yesterday I got a console, and today a Limited GUI (limited meaning I had to use acpi=off)... any help would be appreciated.

Sam_ (and-sam) said : #6

Maybe test 12.04 and upgrade to 12.10?

Since 12.10 the .iso is bigger than a common CD (700mb), so to boot it needs either DVD or USB.
https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/UbuntuDesktop

> Integrated Graphics Controller (rev 09) (says UNCLAIMED in lshw)
> linux confirms the information using 'lspci', and 'lshw'.

Above doesn't mention which chip and driver it uses.
Only as example, the output of lshw should look like this - see 'product' lines:
https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+question/202866

Could it be a RC6 related issue?
https://wiki.ubuntu.com/Kernel/PowerManagementRC6

https://wiki.ubuntu.com/DemystifyingUnityGraphicsHardwareRequirements

Success! After 3 days of messing with this I can finally dual-boot WIndows 8 and Ubuntu 12.10 Secure 64bit. Thank you for your reply, I got it working before I saw it though. I just now got booted back up in WIndows after testing Ubuntu. What I had to do seems kinda weird, but it worked...

1) Insert LiveDVD AND LiveUSB at the same time (the USB let it boot, but it's reading from DVD..weird but it works)
2) Set acpi=off in grub's Try Ubuntu menu entry (Ubuntu Live loads, no xserver errors, no wifi either ofcourse)
3) Install Ubuntu on / partition using free space (that I freed up in Windows using Shrink Volume)
4) Choose /dev/sda2 for bootloader mountpoint (my EFI partition)
5) ...Install went perfect
6) Boot into Ubuntu (Windows didn't work at this time)
7) Run Boot-Repair (crash-dumped on me, tryed Windows entry with no success, restarted into Ubuntu)
8) apt-get update + apt-get upgrade
9) Run Boot-Repair
10) Restart
11) Grub menu now shows Ubuntu, Advanced Ubuntu, Windows 8, Windows Recovery, + some other efi files I don't know
12) Voila! Dual-boot works, no xserver errors.

...I just need to install the correct drivers for my wireless mouse & wifi and I'll be set. I'm just glad to see it load both Ubuntu and Windows successfully right now. Thanks everyone, I'll debug the rest hopefully.

I falsely reported why my setup was working. All of the above is true for getting Ubuntu to install correctly. On further inspection I noticed that acpi=off was set by default (maybe because I was using it during the install), which is why my wireless mouse & wifi weren't working. This did allow me to get it installed on my hard drive, and dual-boot correctly. However, more needed to be done to get EVERYTHING working. I removed acpi=off and I was back where I started (black boot screens, really really dark after splash screen). After looking at some other posts about screen brightness I felt like an idiot. Next time I booted up and the screen was dark, I pressed the Brightness+ button on my laptop. To my surprise the screen brightened up perfectly, probably would've worked the whole time. So it's not an XOrg problem, but an acpi problem. (Excuse: I own several Desktop machines, but this is my first laptop, which is probably why the Brightness+ button escaped me. I never use it on my desktop monitors..)

Brightness Fix:
I used the button on my laptop to set the brightness how I like it and then checked the values in:
    /sys/class/backlight/acpi_video0/brightness
     " "/max_brightness <-to see how high I could actually set it without breaking things
    /sys/class/backlight/intel_backlight/brightness
    " "/max_brightness ...they're not set to max, I just wanted to see what the max was.

I edited /etc/init.d/rc.local to echo the correct value for my machine into:
    /sys/class/backlight/acpi_video0/brightness
   /sys/class/backlight/intel_backlight/brightness
   ..for example: echo 4882 > /sys/class/backlight/intel_backlight/brightness

...Everything works beautifully now. The thing is, as I am writing this I am looking at /etc/init.d/rc.local and both of my entries are gone. Probably overwritten by upgrades or installs (I have been setting my machine up lately). So why does it still work? I don't know, probably because KDE is setting the values somewhere now. I changed the values in System Settings to see if they worked, KDE probably handles the brightness now. As long as it works I don't care, at least I know a workaround if it happens again. I just wanted to post this update for anyone else having the same problems with an HP laptop, Intel Integrated Graphics. Xorg.conf was not needed. I updated my kernel also, but this was after everything was working.