Ubuntu

Black screen on Ubuntu 12.10 with Intel i915 video

Asked by Warren Post on 2012-12-27

Booting Ubuntu 12.10 on a box with Intel i915 video, the screen goes black early in the boot process and remains so. Details are these:

The box in question is a new HP 1000-1210LA laptop. "lspci | grep ]VGA" identifies the video chipset as "Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)". Running Smolt from an OpenSUSE live CD further identifies it as an Intel i915. A web search shows the correct driver is provided by xserver-xorg-video-intel, which is installed.

Whether booting 12.10 from live media or from a hard disk install, booting without kernel parameters results in the screen going black early in the boot process. Seconds later I hear the bongo system ready sound, indicating that the box is booting. A workaround is to boot with the kernel parameter "acpi=off": video works as expected, although of course without the ACPI features one expects on a laptop.

Searching the web, I located and tried numerous suggestions, none of which worked on this hardware. The kernel parameters video=LVDS-1:d, video=LVDS-1:e, noacpi, console=tty1, and i915.modeset=0 all silently failed, as did removing the default parameter "splash". Likewise this advice to modify grub's settings also failed with no change:

https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo#Option_3_-_915_Resolution

For what it's worth, the Mageia 2 live CD exhibits the same symptom. In Mageia's case, the kernel parameter "xdisplay=vesa" resolves the issue without sacrificing ACPI. This would be an acceptable solution here; I don't anticipate needing anything beyond the basic vesa driver in any case.

What else might I try to get video working on this laptop?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-12-28
Last query:
2012-12-28
Last reply:
2012-12-28

Try:

nomodeset

Warren Post (warren-post) said : #2

Many thanks. Trying nomodeset, booting hangs. Pressing esc to skip the splash screen and see boot messages, the final message before hanging is "saned disabled; edit /etc/default/saned"

I do not have a printer currently configured or attached to the box, nor have I done anything with sane or the printing system.

Try:

i915.blacklist=1

Warren Post (warren-post) said : #4

Success! Many thanks.

Should I report this somewhere? You've helped me; now it's my turn to help the community.

Warren Post (warren-post) said : #5

Thanks actionparsnip, that solved my question.

Get fully updated and reboot without the option. /is it ok?

Warren Post (warren-post) said : #7

No, I continue to require the kernel boot parameter. I should have mentioned in my original question that the system was fully updated before seeking help. Presumably I should add this parameter to grub per:

https://help.ubuntu.com/community/BootOptions#Changing_boot_options_Permanently_for_an_Existing_Installation

run:
gksudo gedit /etc/default/grub

change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.blacklist=1"

Save the new file, close gedit and run:
sudo update-grub

Reboot to test

Warren Post (warren-post) said : #9

I had just done that when I saw your message -- many thanks! And yes, it works across reboots. Problem solved.

Rich (rodhull) said : #10

Is there any way anyone has found on successfully using the i915 driver (or another more Intel-specific one) for this hardware instead of the VESA option?

I have an Acer Revo RL80 nettop which appears to have the same "Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)" and I had to also blacklist i915 to get it to install and boot Quantal.

This obviously means we lose out on accelerated graphics/video decoding etc.

Simon Davy (bloodearnest) said : #11

I have the same problem, again on the revo RL80.

I eventually got 12.04.1 installed, using nomodeset, which I have added to the grub config.

What is the different between nomodeset and blacklisting i915? Is one prefered over the other?

Am also wanting to get hw video decoding working, as the intention is for use with xbmc.

In the i915 kernel driver, there is a list of cards needing the invert_brightness=1 setting to work. Unfortunately, there are very few device entries in that list at the moment. Perhaps those of you with laptops experiencing this problem could push to get your device into that list?

See http://people.skolelinux.org/pere/blog/Fixing_the_Linux_black_screen_of_death_on_machines_with_Intel_HD_video.html for the information I have found so far on how to get this problem permanently fixed in the Linux kernel.