Video scaling problem gma950 dell ubuntu 12.10

Asked by Dariusz Macholl on 2012-10-20

I've got a problem with my dell d430 with c2d u7600 and gma950. When i run any fullscreen app in any other resolution than my native resolution (which is 1280x800) then the video is incorrectly scalled - i see only ~1/4 of the video, it really annoys me, cause i can't play any game in low resolution (gma950 isn't too powerful so i can't play most games in native resolution), the problem occurs on any renderer - OpenGL, SDL or DirectX (via wine). the problem did not occur on Ubuntu 12.04 - everything was running fine until i upgraded to Ubuntu 12.10 (well, i didn't upgrade, i've made a clean install). What I can do to see correctly scalled games in resolution such as: 640x480, 800x600, 1024x768?
There are some links to photos of these problems:
Only 1/4 of video is visible on the screen:
https://dl.dropbox.com/u/16115636/SAM_0383.JPG
After killing the process of blobby volley via bash:
https://dl.dropbox.com/u/16115636/SAM_0385.JPG
On native resolution everything is fine:
https://dl.dropbox.com/u/16115636/SAM_0386.JPG

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-20
Last reply:
2012-10-20

Can you give the output of:

sudo lshw -C display; slb_release -a; uname -a; sudo dmidecode -t 1

Thanks

Dariusz Macholl (daro16-1995) said : #2

"sudo lshw -C display" gives me:
  *-display:0
       description: VGA compatible controller
       product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:eff00000-eff7ffff ioport:eff8(size=8) memory:d0000000-dfffffff memory:efec0000-efefffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:eff80000-efffffff

slb_release gives me information that there is no such command, but there is lsb_release -a which gives me:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

and sudo dmidecode -t 1 gives:
# dmidecode 2.11
SMBIOS 2.4 present.

Handle 0x0100, DMI type 1, 27 bytes
System Information
 Manufacturer: Dell Inc.
 Product Name: Latitude D430
 Version: Not Specified
 Serial Number: BP4G93J
 UUID: 44454C4C-5000-1034-8047-C2C04F39334A
 Wake-up Type: Power Switch
 SKU Number: Not Specified
 Family:

Also, i've tried on my other computer, which has Intel Q35 Graphics card and there is exacly the same problem. Also, on the external monitor the problem still occurs.

Thanks for your interest in my problem

I suggest you report a bug with xorg

Can you help with this problem?

Provide an answer of your own, or ask Dariusz Macholl for more information if necessary.

To post a message you must log in.