Kernel update to 3.2.30 Did not fix my samsung laptop problem!

Asked by Alexander Bumgardner

Ive been having an issue since summer regarding a screen flicker and system freeze. I reported the bug and tested various kernels. The only one that worked, w ubuntu 12.04, was a 3.6.3-rc...blah...blah...blah.

It was a test kernel that worked, and I was running as temporary solution until update finally finished. I then switched to finished updated 3.2.30 kernel, and still have the same problem!

Should I just look through various 12.04 precise-kernels, or should i just revert to using 11.10? I am in grad school and really need my laptop to work!

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Have you tried any boot options regarding backlight? Samsung laptops are notorious for needing at least a few.

Revision history for this message
Alexander Bumgardner (spungotomer42) said :

What do you mean by boot options? It's not just the backlight, the whole system freezes. I think that was part of the problem; my bug was just assumed to be the same as the "Series 900 Laptop brightness control issue". Anyway, all the info on my bug is listed on Bug #1028736

I'm really tempted to just reinstall 11.10. I tried to test a few kernels, but when the latest proposed was put up, I tried but was unable to test it. i posted in ubuntuforums and received no help, and while the folks monitoring launchpad (here) are helpful, they aren't exactly support for new/intermediate users. I don't have a lot of experience yet, and Im in Grad School. I don't have time for this.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Try the boot options:

acpi_osi=Linux acpi_backlight=vendor

May help

Revision history for this message
Alexander Bumgardner (spungotomer42) said :

um... sorry to be dense. Where should I edit this? What file?

Revision history for this message
actionparsnip (andrew-woodhead666) said :


gksudo gedit /etc/default/grub

Find this line:

And change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Save the new file, close gedit and run:
sudo update-grub

reboot to test.

What have you actually tried in order to make this work!!? These boot options are all over pages where people have bought Samsung laptops and are running Ubuntu.....

Revision history for this message
Alexander Bumgardner (spungotomer42) said :

So, mainly I've been following (or trying to follow) a bug report 1028151. My original report was linked to this one, so I've been testing some of the kernels that've been proposed as fixes. However, when we were last asked to test a kernel/fix, it was in the precice-proposed repositories. I couldn't get to it, and the file link was unlike any of the kernels i'd tested heretofore.

I mistakenly believed that the "official update" was included in 3.2.30. But just looking at bug 1028151 they said the fix was in 3.2.28... I'm not sure what to do. I've been using linux since last december, and i've been working pretty hard to learn as much as possible. But at this point I just have no freaking clue what to do.... am i supposed to download the 3.2.28 kernel? And if so, from the mainline ppa's? Then update?

I apologize for whining. just have a lot of other stuff to do. THANKS!

I changed the GRUB_CMDLINE_LINUX_DEFAULT. Currently testing. Sometimes it takes a minute for this "thing" to occur. Will update results in about an hour.

Revision history for this message
Alexander Bumgardner (spungotomer42) said :

Actually, I think your fix worked! Haven't had the pop up/freeze thing. Thanks!

PS- what kernel should I run? 3.2.28, if that's where the supposed fix is, or 3.2.30? Does it matter?

Can you help with this problem?

Provide an answer of your own, or ask Alexander Bumgardner for more information if necessary.

To post a message you must log in.