graphics card fan running and no graphics card drivers installed

Asked by hbomb on 2012-09-08

Why is my graphics card running similar to playing diablo 3 on windows....i dont have compiz running or anything fancy.....

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-13
Last reply:
2012-09-13
Thomas Krüger (thkrueger) said : #1

Please open there Terminal, run the following line (it will ask for your password) and post the outout here:
sudo lshw -c display

Thanks!

Can you give the output of:

sudo dmidecode -t 1; lsb_release -a; uname -a

A few details would be nice.....

Can you give the output of:

sudo dmidecode -t 1; lsb_release -a; uname -a

A few details would be nice.....

Elias Psallidas (eliasps) said : #4

In addition to that, can you give the output of:
lspci -nnk | grep -iA3 vga

hbomb (scarofdivinity) said : #5

On 09/08/2012 10:26 AM, Elias Ps wrote:
> Your question #208029 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208029
>
> Elias Ps posted a new comment:
> In addition to that, can you give the output of:
> lspci -nnk | grep -iA3 vga
>
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd
Generation Core Processor Family Integrated Graphics Controller
[8086:0126] (rev 09)
     Subsystem: Lenovo Device [17aa:21d1]
     Kernel driver in use: i915
     Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF106
[Quadro 2000M] [10de:0dda] (rev a1)
     Subsystem: Lenovo Device [17aa:21d1]
     Kernel driver in use: nouveau
     Kernel modules: nouveau, nvidiafb
astryx@f4113n:~$ ^C

hbomb (scarofdivinity) said : #6

Generation Core Processor Family Integrated Graphics Controller
[8086:0126] (rev 09)
bash: syntax error near unexpected token `('
astryx@f4113n:~$ Subsystem: Lenovo Device [17aa:21d1]
Subsystem:: command not found
astryx@f4113n:~$ Kernel driver in use: i915
Kernel: command not found
astryx@f4113n:~$ Kernel modules: i915
Kernel: command not found
astryx@f4113n:~$ --
--: command not found
astryx@f4113n:~$ 01:00.0 VGA compatible controller [0300]: NVIDIA
Corporation GF106 [Quadro 2000M] [10de:0dda] (rev a1)
bash: syntax error near unexpected token `('
astryx@f4113n:~$ Subsystem: Lenovo Device [17aa:21d1]
Subsystem:: command not found
astryx@f4113n:~$ Kernel driver in use: nouveau
Kernel: command not found
astryx@f4113n:~$ Kernel modules: nouveau, nvidiafb
Kernel: command not found
On 09/08/2012 09:56 AM, actionparsnip wrote:
> Your question #208029 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208029
>
> actionparsnip requested more information:
> Can you give the output of:
>
> sudo dmidecode -t 1; lsb_release -a; uname -a
>
> A few details would be nice.....
>

Thomas Krüger (thkrueger) said : #7

You are using the open Source driver "nouveau", it lacks many power saving fetures. You should switch to the properitaty driver from nVidia. It can be installed with

sudo apt-get install nvidia-current-updates

hbomb (scarofdivinity) said : #8

On 09/09/2012 09:35 AM, Thomas Krüger wrote:
> Your question #208029 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208029
>
> Status: Open => Answered
>
> Thomas Krüger proposed the following answer:
> You are using the open Source driver "nouveau", it lacks many power
> saving fetures. You should switch to the properitaty driver from nVidia.
> It can be installed with
>
> sudo apt-get install nvidia-current-updates
>
>
Reading package lists... Done
Building dependency tree
Reading state information... Done
nvidia-current-updates is already the newest version.
The following packages were automatically installed and are no longer
required:
   language-pack-zh-hans language-pack-kde-en language-pack-kde-zh-hans
   language-pack-kde-en-base kde-l10n-engb kde-l10n-zhcn
   language-pack-zh-hans-base firefox-locale-zh-hans
   language-pack-kde-zh-hans-base
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

hbomb (scarofdivinity) said : #9

On 09/09/2012 10:26 AM, hbomb wrote:
> Your question #208029 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208029
>
> Status: Answered => Open
>
> You are still having a problem:
> On 09/09/2012 09:35 AM, Thomas Krüger wrote:
>> Your question #208029 on Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+question/208029
>>
>> Status: Open => Answered
>>
>> Thomas Krüger proposed the following answer:
>> You are using the open Source driver "nouveau", it lacks many power
>> saving fetures. You should switch to the properitaty driver from nVidia.
>> It can be installed with
>>
>> sudo apt-get install nvidia-current-updates
>>
>>
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> nvidia-current-updates is already the newest version.
> The following packages were automatically installed and are no longer
> required:
> language-pack-zh-hans language-pack-kde-en language-pack-kde-zh-hans
> language-pack-kde-en-base kde-l10n-engb kde-l10n-zhcn
> language-pack-zh-hans-base firefox-locale-zh-hans
> language-pack-kde-zh-hans-base
> Use 'apt-get autoremove' to remove them.
> 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
>
Im working on a backup right now of my settings then im going to work on
installing new drivers....shouldnt openGL work as well?

Copy the below command as ONE command:

sudo lshw -C display; sudo dmidecode -t 1; lsb_release -a; uname -a

Press CTRL+ALT+T and paste the entire command to the terminal and hit ENTER. Type your login password and hit ENTER. Wait a while while it runs and then copy the entire output and paste it here as an update.

Thanks

hbomb (scarofdivinity) said : #11

I tried numerous ways to install the nvidia driver but then just restored it to its orginal state because it seemed to harder with 640 resolution screen

astryx@f4113n:~$ sudo lshw -C display; sudo dmidecode -t 1; lsb_release -a; uname -a
[sudo] password for astryx:
  *-display
       description: VGA compatible controller
       product: GF106 [Quadro 2000M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:f0000000-f1ffffff memory:c0000000-cfffffff memory:d0000000-d3ffffff ioport:5000(size=128) memory:f2000000-f207ffff
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:51 memory:f2400000-f27fffff memory:e0000000-efffffff ioport:6000(size=64)
# dmidecode 2.11
SMBIOS 2.6 present.

Handle 0x0014, DMI type 1, 27 bytes
System Information
 Manufacturer: LENOVO
 Product Name: 4270CTO
 Version: ThinkPad W520
 Serial Number: R9G2N7H
 UUID: FB2F0F81-508C-11CB-A280-F1EB264B0A20
 Wake-up Type: Power Switch
 SKU Number: Not Specified
 Family: ThinkPad W520

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux f4113n 3.2.0-30-generic-pae #48-Ubuntu SMP Fri Aug 24 17:14:09 UTC 2012 i686 i686 i386 GNU/Linux

You have a hybrid video system which is a LOT of headache under Linux. I have never seen a success story. You may get luck with this:
https://help.ubuntu.com/community/HybridGraphics

But if you can, disable one of the GPUs and just use one GPU. Try:

echo "OFF" | sudo tee /sys/kernel/debug/vgaswitcheroo/switch

Can you help with this problem?

Provide an answer of your own, or ask hbomb for more information if necessary.

To post a message you must log in.