Ubuntu 12.04 on Dell computer: reboot problem

Asked by Ting Lin on 2012-08-29

I have Ubuntu 12.04 installed on my Dell computer. I have a second hard drive on this computer.

I use to have a duel Windows/Linux system on this computer, with Windows on sda Ubuntu on sdb, and had no problem till some system update around June. After the upgrade the computer got stuck when restart.

I reinstalled Ubuntu and got into grub-rescue mode.

I then used Ubuntu Live on usb and boot-repair to fix the problem.

After that I can turn on the computer from shut-down mode, but it still got stuck if I restart it.

I also lost the access to Windows through this. I then reisntall Ubuntu again and use only Linux OS.

At the beginning, sometimes I can restart the computer sometimes I cannot.

But now the computer get stuck in restart sequence everytime I try. There is no problem if I simply shut down the computer and start it again.

I have tried Boot Repair, but it didn't help.

I also emailed Boot Repair, a guy told me he couldn't help me and directed me to Ubuntu Launchpad.

May I know what should I do to fix the problem?

Your help is greatly appreciated.

Thanks,
Ting

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-09-05
Last query:
2012-09-05
Last reply:
2012-08-29
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,
yes boot-repair will correct only boot problems , not restart or shutdown problems. These are problems, usually caused by acpi or graphics card driver.

Provide more info .
Open a terminal with ctrl+alt+t and paste the results of below commands
++++++++++++++++++++++++++++
lspci -nnk | grep -iA2 vga
sudo dmidecode -t 2
uname -r
++++++++++++++++++++++++++++
also try an older kernel if you have. Usually you will find it under "Previous Linux Versions" in grub menu.

Thanks

Ting Lin (linting262) said : #2

lin@cyclamen:~$ lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e12] (rev 03)
 Subsystem: Dell Device [1028:0420]
 Kernel driver in use: i915
lin@cyclamen:~$ sudo dmidecode -t 2
Hi,
Thanks for your reply. Here are the outputs:

[sudo] password for lin:
# dmidecode 2.11
SMBIOS 2.5 present.

Handle 0x0200, DMI type 2, 8 bytes
Base Board Information
 Manufacturer: Dell Inc.
 Product Name: 0C27VV
 Version: A00
 Serial Number: ..CN1374099601L9.

lin@cyclamen:~$ uname -r
3.2.0-29-generic-pae
lin@cyclamen:~$

Ting Lin (linting262) said : #3

By the way, I do have a graphic issue just this week. I have got a message like compiz is still running or not responding when I attempted to shut down the computer and cause the computer to freeze if I just go ahead to shut down the computer. Now I use ubuntu2d to avoid compiz.

Best N1ck 7h0m4d4k15 (nicktux) said : #4

Hi ,
is this a Dell Inspiron computer ? I found a newer version of Bios here > http://www.dell.com/support/drivers/us/en/19/DriverDetails/DriverFileFormats?c=us&s=dhs&cs=19&l=en&DriverId=R93239 , the A01 . If you want to try to upgrade ... I don't know the way from Linux, it has only windows upgrade program.
Bios upgrades are dangerous and can harm your system. So if you decide to do this , do it with your own risk.

Second suggestion: Upgrade your graphics driver version (xserver-xorg-video-intel) . Add a stable external ppa with bellow commands and upgrade (This is safe and you can revert back if you want)
+++++++++++++++++++++++++++++++++++++++++++++++++
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get dist-upgrade
+++++++++++++++++++++++++++++++++++++++++++++++++

In case you want to revert back (undo) apply these commands
+++++++++++++++++++++++++++++++++++++++++++++
sudo apt-get get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get dist-upgrade
+++++++++++++++++++++++++++++++++++++++++++++

Third suggestion: This is a workaround , not a solution. Adding a parameter to the kernel via grub bootloader.
Open the file
++++++++++++++++++++++++++++++
gksudo gedit /etc/default/grub
++++++++++++++++++++++++++++++

find the line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=a,w"

save the document and run in terminal
++++++++++++++++++++
sudo update-grub
+++++++++++++++++++
reboot.

Apply above suggestions one at time , not all together. Hopefully something will work.

Thank you

Ting Lin (linting262) said : #5

Hi,

This is a Dell Inspiron.

I tried your second suggestion to upgrade the graphics driver version, and it works.

Thanks a lot,
Ting

N1ck 7h0m4d4k15 (nicktux) said : #6

Hello Ting .
Please mark this question as solved , by marking the answer that helps you.

Thank you.

Ting Lin (linting262) said : #7

Just to correct the information about my computer. I guess this kind of things happens when you have more than one desktop/laptop. It is not a Dell inspiron, it is Dell Optiplex 780 desktop.

Ting Lin (linting262) said : #8

Thanks NikTh, that solved my question.