Laptop display boots to black v12.04

Asked by Aaron Skewes on 2012-08-15

I just installed 12.04 on my HP Pavilion dm4 laptop. It has an Intel HD Graphics card. After the grub boot loader screen, the display goes black. The strange thing is if I connect the laptop to an external monitor, I can get the video signal on the external monitor. This indicates to me that the issue is not with the graphics card. I have tried to configure the laptop display from the video settings in Ubuntu, but no go.

Any ideas how to get my laptop display to work?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-08-16
Last query:
2012-08-16
Last reply:
2012-08-16
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,
turn to Console mode (ctrl+alt+F2) and when you connect with username and password apply these commands

========================================================
sudo service lightdm stop
sudo apt-get update
sudo apt-get dist-upgrade
sudo dpkg-reconfigure lightdm xorg xserver-xorg xserver-xorg-core
sudo service lightdm start
========================================================
Be aware that you will have no display , so write down above commands (to a paper or mobile photo) to apply them correctly .

Tell me if your problem solved.
Thanks

Try the boot option:

nomodeset

Hopefully updates will fix the issue.

Aaron Skewes (askewes) said : #3

Thank you Nick,

I did as you suggested. however I am stuck on:
sudo dpkg-reconfigure lightdm xorg xserver-xorg xserver-xorg-core

when I do this, I get a screen asking me to chose a default graphics server. there are two selections 1)lightdm and 2)xorg.

what to chose?

best,
-AS

nomodeset will probably be ok for you

N1ck 7h0m4d4k15 (nicktux) said : #5

Hi ,
You must choose lightdm and then proceed with other command.

Otherwise nomodeset as @actionparsnip suggested will be fine.

How you will boot with nomodeset option ?
First test it and see if works..
When you are in grub menu , highlight Ubuntu entry and press 'e' , then with arrow keys go after "splash" leave a space and write nomodeset , then press F10 to boot with this option.

Thanks

Aaron Skewes (askewes) said : #6

nomodeset seems to solve it. Thanks to all for the help!

I also am experiencing this issue on my Dell Latitude E5510, with the Intel Core i7 integrated graphics. This only started happening to me starting on Thursday, 2012-10-18, probably due to some recent updates (it had been working perfectly with an external display since I installed 12.04 a few months ago). If I use the nomodeset kernel boot option, then it works correctly using the internal laptop display, but is unable to connect to an external display. The internal display is used correctly for the BIOS and GRUB menus, and works just fine (as it always has) when I dual-boot into Windows 7.

  *-display UNCLAIMED
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f0000000-f03fffff memory:e0000000-efffffff ioport:8080(size=8)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux broderick 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux