HDMI not working (First Time Ubuntu/Linux) User

Asked by rh1 on 2012-07-31

I recently installed Ubuntu on my desktop.

Specs: i3 cpu
Ram: 4gb
Motherboard: J&W-H55M-L, this motherboard has a integrated HDMI, and uses the Intel H55 express Chipset

The VGA works but I would like to connect it to my 32 Samsung tv (sq01) via HDMI but there is no picture

regards

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
rh1
Solved:
2012-08-03
Last query:
2012-08-03
Last reply:
2012-08-02

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; sudo dmidecode -t 1

Thanks

rh1 (renaldoh) said : #2

rh1@rh1-desktop:~$ sudo lshw -C display; lsb_release -a; uname -a; sudo dmidecode -t 1
[sudo] password for rh1:
  *-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:48 memory:fb800000-fbbfffff memory:d0000000-dfffffff ioport:dc00(size=8)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux rh1-desktop 3.2.0-27-generic #43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
# dmidecode 2.11
SMBIOS 2.6 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: To Be Filled By O.E.M.
 Product Name: To Be Filled By O.E.M.
 Version: To Be Filled By O.E.M.
 Serial Number: To Be Filled By O.E.M.
 UUID: 03000200-0400-0500-0006-000700080009
 Wake-up Type: Power Switch
 SKU Number: To Be Filled By O.E.M.
 Family: To Be Filled By O.E.M.

Does the system have a make and model?

rh1 (renaldoh) said : #4

no, its a tower pc

rh1 (renaldoh) said : #5
N1ck 7h0m4d4k15 (nicktux) said : #6

Hi ,

maybe I ask something stupid now , but no offense , I did it my self in the past :P

You said that HDMI is integrated to motherboard. Do you have a PCI graphics card also ? If yes then you must Unplug PCI for integrated to work .
Or look if integrated card is Enabled in Bios.

Thanks

rh1 (renaldoh) said : #7

@ NikTh

No i dont have a PCI graphics card connected, but I do have a PCI-E usb 3.0 card connected, could this affect it as well?

Regards

N1ck 7h0m4d4k15 (nicktux) said : #8

Hi ,
No, I think its Ok with Usb3.0 . I spoke about PCI(or PCI-E) graphics card , cause if you plug in then integrated will disabled.

Now , open a terminal and give the output of

====================
lspci -nnk | grep -iA2 vga
====================

and also check your TV , maybe wants something from the menu ,to change. At my tv , it wants to select the input device first (HDMI) .

Also try something else, first open your Computer and After plug in the HDMI cable to TV.

Thanks

rh1 (renaldoh) said : #9

rh1@rh1-desktop:~$ lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 12)
 Subsystem: Intel Corporation Core Processor Integrated Graphics Controller [8086:0042]
 Kernel driver in use: i915

N1ck 7h0m4d4k15 (nicktux) said : #10

Hi ,
can you please post the output of

==================================
cat /var/log/Xorg.0.log | grep -e WW -e EE
==================================

Did you try the suggestions above ?

1)About TV menu and input device (Is your TV has such menu?)

and try also below :

2)First open monitor and then open computer.

Thanks

rh1 (renaldoh) said : #11

Hi NikTh

I have tried the various combinations of connecting the computer to the TV (including the suggestions above and then some)

rh1@rh1-desktop:~$ cat /var/log/Xorg.0.log | grep -e WW -e EE
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 1542.719] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 1542.719] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 1542.719] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 1542.719] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 1542.719] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 1542.719] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[ 1542.721] (II) Loading extension MIT-SCREEN-SAVER
[ 1542.730] (WW) Falling back to old probe method for vesa
[ 1542.730] (WW) Falling back to old probe method for fbdev

In my documents folder there is this document Output with the following lines amongst others:

[ 17.487] (II) config/udev: Adding input device HDA Intel Front Headphone (/dev/input/event10)
[ 17.487] (II) No input driver specified, ignoring this device.
[ 17.487] (II) This device may have been added with another device file.
[ 17.488] (II) config/udev: Adding input device HDA Intel Line-Out (/dev/input/event11)
[ 17.488] (II) No input driver specified, ignoring this device.
[ 17.488] (II) This device may have been added with another device file.
[ 17.488] (II) config/udev: Adding input device HDA Intel HDMI/DP,pcm=8 (/dev/input/event4)
[ 17.488] (II) No input driver specified, ignoring this device.
[ 17.488] (II) This device may have been added with another device file.
[ 17.488] (II) config/udev: Adding input device HDA Intel HDMI/DP,pcm=7 (/dev/input/event5)
[ 17.488] (II) No input driver specified, ignoring this device.
[ 17.488] (II) This device may have been added with another device file.
[ 17.489] (II) config/udev: Adding input device HDA Intel HDMI/DP,pcm=3 (/dev/input/event6)
[ 17.489] (II) No input driver specified, ignoring this device.
[ 17.489] (II) This device may have been added with another device file.
[ 17.489] (II) config/udev: Adding input device HDA Intel Line (/dev/input/event7)
[ 17.489] (II) No input driver specified, ignoring this device.
[ 17.489] (II) This device may have been added with another device file.
[ 17.489] (II) config/udev: Adding input device HDA Intel Front Mic (/dev/input/event8)
[ 17.489] (II) No input driver specified, ignoring this device.
[ 17.489] (II) This device may have been added with another device file.
[ 17.489] (II) config/udev: Adding input device HDA Intel Rear Mic (/dev/input/event9)
[ 17.489] (II) No input driver specified, ignoring this device.

N1ck 7h0m4d4k15 (nicktux) said : #12

Hi ,

I cannot see anything notable in log.

If hardware is not the problem , I think you can convert the question in to bug.

Although It will be wise to wait few days for someone else (more experienced) to answer.

Thanks

rh1 (renaldoh) said : #13

Thank you NikTH

I went and purchase a NVIDIA graphics card today, which pick up first time, I have updated the NVIDIA drivers and rebooted. There is a slight problem as Ubuntu is currently identifying the my samsung 32 inch as a 46 inch tv and resizing it. i.e. the display layout is bigger than the actual screen

But I am sure it is easily fixed

Regards