Display flicker on Samsung Series 9 NP900x4c on Ubuntu 12.04

Asked by Rohan Mitchell on 2012-07-31

Hi!

I recently bought a Samsung Series 9 NP900x4c laptop and installed Ubuntu 12.04. I'm getting an intermittent display flicker where the display jitters horizontally.

The laptop has an Intel chipset "Integrated Graphics Chipset: Intel(R) Ivybridge Mobile (GT2)" and uses the i915 kernel driver and intel Xorg driver.

I've tried adding the following to /etc/modprobe.d/i915-kms.conf:

options i915 modeset=0

When I reboot with this line present, gnome shell fails to start, complaining about a lack of hardware acceleration. Gnome classic starts as a fallback and it *does not flicker*. Looking at /var/log/Xorg.0.log, it looks like the vesa driver is being used instead of intel. However, I can't switch ttys (ctrl+alt+f1 etc.) - the system locks up if I do, and it also locks up if I suspend. This is in addition to having no hardware acceleration and not being able to run gnome shell, so it's not a great solution.

I've also tried:

options i915 powersave=0

That had no noticeable effect.

There seems to be some sort of correlation between the problem and CPU usage. While I'm at 100% CPU utilisation (stress --cpu 4), the problem goes away, but comes back straight away after stopping stress. The problem also seems to be particularly bad after resuming from suspend. I'm dual booting Windows 7, and I have yet to observe the problem while running Windows.

Any ideas what the problem might be? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Rohan Mitchell
Solved:
2012-08-02
Last query:
2012-08-02
Last reply:
2012-07-31

Do you have the latest BIOS in the system?

Rohan Mitchell (rohanm) said : #2

Thanks for getting back to me :) I did not have the latest BIOS, but in the process of upgrading it I noticed the fault occurring under windows also, suggesting it was a hardware fault. I was able to get a replacement laptop, and there's no sign of the problem after a day of heavy usage. Consider it solved :)

Timo Ewalds (timo-ewalds) said : #3

I saw something similar on the default 3.2 kernel, but I haven't seen it since I upgraded to 3.4.