Weird error (bug???) on my screen

Asked by thom on 2012-06-21

Here is my laptop spec :
Type : ASUS A43E-VX389D
Video Card : Intel HD Graphic
Memory : 2 GB DDR3
Processor : Intel B950 ( 2.1 GHz, 2MB L3 cache )

and I'm using Ubuntu Precise Pangolin 64-bit on Gnome Classic session, with graphic card, detected as Intel Sandybridge Mobile. Now, I've the following error (I uploaded the screenshot in an image hosting) :
1. The error start appearing - http://i.imgur.com/0zvSf.png
2. I scrolled down, the error fullfill the whole window's browser - http://i.imgur.com/oczVU.png
3. I clicked restore button, the error disappear - http://i.imgur.com/UlQgk.png
4. I clicked maximize button - http://i.imgur.com/KmDIW.png

Sometimes, it's just partial. Sometimes, I could get 'the error' almost a whole screen. And happen frequently. FYI, if I maximized the window, the 'error' sometimes gone. And if it still there, I just minimized/ maximized/ restore the window till it's gone. Its all information I could give. Hope someone could help me out..

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-06-21
Last query:
2012-06-21
Last reply:
2012-06-21

Is it just in Chrome that you get the issue?

thom (iamthom) said : #2

No. I could get the error in any window. For example, http://i.imgur.com/HFksc.png

Are you fully updated?

thom (iamthom) said : #4

Yes, I am.

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

thom (iamthom) said : #6

Here you are :

*-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:dd000000-dd3fffff memory:c0000000-cfffffff ioport:e000(size=64)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux thom-lappie 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Try the boot option:

nomodeset

May help...

thom (iamthom) said : #8

I am still trying it. If, this help, so it solved (although by sacrificing the compiz, it's OK with me).. Umm,, sorry, but may I know the decision of my problem?

thom (iamthom) said : #9

Ups,, I exactly forgot to ask these :
1. Is it still possible to enable some effects?
2. I just set 'nomodeset' in a moment ago (on the fly) . In the next boot, should I set the boot options again?

FYI, So far, the error doesn't appear yet. Thankyou for your help & your kindness.

thom (iamthom) said : #10

Thanks actionparsnip, that solved my question.