Ubuntu 12.04 fails to find Intel HD Graphics 3000 driver

Asked by iatll

On my Windows 7 installation an Intel HD Graphics 3000 card/driver shows. However in Ubuntu 12.04, System → Administration → Hardware Drivers shows no proprietary drivers available for the system.

I have tried running the following:

sudo apt-get install mesa-utils

Which results in the graphics driver incorrectly identifying itself as Sandy Bridge Mobile.

Running the following results in no change

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update && sudo apt-get upgrade
sudo reboot

Does anybody have any information on this behavior?

Question information

English Edit question
Ubuntu xserver-xorg-video-intel Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
michael (yellupcm-gmail) said :
Revision history for this message
iatll (iatll) said :

Went through those links, didn't help. Solution is probably that there is no other graphics driver available other than Intel Sandybridge Mobile