Ubuntu 12.04 - Hangs when connecting external monitor [Dual Monitor/ Multiple Monitor bug]

Asked by Terry S on 2012-04-30

Using Dell Inspiron 1501 laptop. Works fine in single screen mode, resolution 1366x768

Connecting external monitor (resolution 1400x900) after machine booted causes system to hang, requiring hard reboot. Mouse visible on left hand edge of external monitor screen (positioned to the right of the laptop screen), but otherwise both screens are black/blank

Connecting external monitor before booting causes hang after login (it never gets to the desktop, just shows the splash screen background tiled)

Worked fine with 11.10. Stopped working with 12.04

I'm aware I should probably be posting the output of something here, but not sure what: guidance appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Terry S
Solved:
2012-06-12
Last query:
2012-06-12
Last reply:
2012-05-18

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Terry S (itsterry) said : #2

Wow! Speedy response!

Here's the output of sudo lshw -C display; lsb_release -a; uname -a

 *-display:0
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:f6c00000-f6ffffff memory:e0000000-efffffff ioport:efe8(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f6b00000-f6bfffff
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

Terry S (itsterry) said : #3

That output is without the external monitor connected (or we wouldn't see anything!)

Terry S (itsterry) said : #4

And here's the weird thing. I have the EXACT SAME make and model external monitor at home (I bought the two together).

When I plug in the external monitor at home, everything works (monitor plugged in pre-boot).

When I plug it in the office, it hangs. To pre-empt the next question, everything was fine on Friday in the office, before I upgraded to 12.04.

Is there a per-monitor configuration I should be inspecting maybe?

Bryan (k1cd) said : #5

same problem here with an Acer i3 laptop. When the HDMI 1920x1200 monitor is attached, the system hangs with a blank screen after login.

This only appeared at about alpha2, before that it worked just like in 10.10 where the driver is the i915

at times during the development process, I was able to re-install to a default configuration and get both monitors but when I tried to do anything to change from the default mirror side by side, I lost it. Usually it'd hang on 'apply changes' and require a power down reboot which would come back without the changes. Often enough, though, a reboot just hit blank screen hang after login.

Medya (medya) said : #6

I have the same problem , I upgraded from 11.10 64bit to ubuntu 12.04

I have toshiba laptop with intel graphic and an external monitor

TaleRix (talerix) said : #7

Same problem here with a Samsung laptop, Intel graphics and External TV (via HDMI). BTW I use Kubuntu 12.04 64bit

Diniz (wagnerdd) said : #8

Here when I connected the computer with the monitor plugged he entered the normal way "mirror", when I changed the mode to extend the X crashed.
By default the extended configuration assumes that the monitor is on the right side of the Laptop, this configuration LOCK, enabling it to "extend" and position the monitor to the left side of the laptop works 100%.

Terry S (itsterry) said : #9

Forgive me if I'm being a dufus, but I saw that the status had changed to "Fix released" (although it's now "open" again).

If there's a fix, is there a howto on applying it (applying patches is a bit new to me), or will it show up if I run in apt-get update?

Apologies again for the n00b question !

I am facing the same problem here. I have a Toshiba Satellite a300-14t notebook and as i am connecting the external monitor the graphic interface hangs.
I feel a bit disapointed now because i have just installed the long waited 12.04. And the promise was that the multi monitor experience will be better than before.

yaron (yaronv99) said : #11

i had the same problem with asus zenbook ux21 i5.
Fixed it by installing an older version of the package xserver-xorg-input-evdev.
I downloaded the deb file and installed it from terminal.

Terry S (itsterry) said : #12

Added link to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/992778 where it looks like there's a solution for people who don't have latest xserver-xorg-input-evdev yet, but still having the problem

Terry S (itsterry) said : #13

All working for me in latest Ubuntu update. Thank you, excellent Ubuntu/Xorg devs!

I have fully updated system and the _exact_ same problems still persists on Toshiba Staellite C650. After plugging external display, notebook screen goes black and external display shows mouse cursor on the left edge of the screen, and the rest is also black. In this state notebook so completely forzen, so I can not go to th tty1-6 via ctrl+alt+f1.

jpt (jpt) said : #15

I have also exactly same problem on HP EliteBook 2530p. If I connect the external display to the laptop, both screens go black and mouse cursor is shown on the left edge of the external screen. A few updates ago everything was working fine and now nothing seems to help.

In general, it feels like the support for multiple displays seems to get worse every time when Ubuntu gets updated.