Intel Graphics Problem

Asked by Joshua Ulysse on 2012-04-26

I have Ubuntu 12.04 LTS Beta on an Acer Aspire One ZG5 net book with a

Mobile Intel(R) 945 Express Chip-set Family card

I've installed Ubuntu 11.04 last year two days before the release of 11.10. Right after I installed the KDE Plasma Desktop, my graphics fell off a cliff.

My unity started putting me on 2D mode, Gnome on classic, and on KDE I had to use X render. Months after searching for graphics problems I found out when I checked "Details" in System Settings and on the list for graphics it showed NONE! I tried searching for Intel drivers, but that's like searching for Gold on a sidewalk.

Even When I do find some sort of driver, I can't find a way to use it. The Additional drivers list would not help either.

I have three other operating systems

-Windows 7

-Linux mint

-Pinguy OS

Those ones don't have any problems with my card

I upgraded from 11.10 to 12.04 LTS beta in hope of Canonical including my card in their driver list, and again it didn't work.

I'd appreciate anyone's word on this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Joshua Ulysse
Solved:
2012-05-08
Last query:
2012-05-08
Last reply:
2012-04-27

The driver is in the default OS so you wont find Intel drivers to manually install.

Pinguy and Mint are based on Ubuntu so multibooting between is obscure.

If you wipe out Ubuntu and install a clean install of Precise you'll probably find its ok.

Joshua Ulysse (joshulysse) said : #2

I've thought of that before, but reinstalling programs and other things (HEADACHE)

Joshua Ulysse (joshulysse) said : #3

Do you still think I could copy drivers from another OS? (exept Windows 7)

[p.s. I don't have separate computers, all are in one]

Joshua Ulysse (joshulysse) said : #4

YAHOOOOOOOOOOOOOOOOOOOOO!!!!!!! I fiXed it

i fixed it by going to linux mint and checking the package manager for opengl files and i went to ubuntu to apply installation of missing files!!!!!!!!!!!