Low resolution on Intel mobile 4 and Lubuntu 12.04 64 bit

Asked by stefano.fraccaro on 2012-04-24

I have a newly installed Lubuntu 12.04 64 bit but LXRandr has only 1024x768 resolution available.

I can't switch to 1366x768 that is the best resolution for my ACER 5735 laptot.

I have tried xrandr from the command line without success: I can choose the new resolution from LXRandr but the monitor don't change resolution.

I'm missing something? There is something to install?

Best regards
Stefano

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2012-04-27
Last query:
2012-04-27
Last reply:
2012-04-27

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks.

stefano.fraccaro (sf-1) said : #2

  *-display:0 UNCLAIMED
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:4110(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:d3400000-d34fffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux utente-TravelMate-5735 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

You may need an xorg.conf file if your monitor isn't doing what it should do.

stefano.fraccaro (sf-1) said : #5

https://wiki.ubuntu.com/X/Config/Resolution don't resolve my problem. Max resolution is not correctly detected and when I create a new resolution for 1366x768, cvt create a resolution of 1368x768 that is not supported by this monitor

Best Sam_ (and-sam) said : #6

Since autodetect is expected to work consider to report a bug.
ubuntu-bug xorg

https://help.ubuntu.com/community/DebuggingXAutoconfiguration

stefano.fraccaro (sf-1) said : #7

Thanks Sam_, that solved my question.

Juankof (juankof) said : #8

Same problem on Acer Aspire 4736 and ubuntu 12.04

Juankof (juankof) said : #9

This is really solved?

stefano.fraccaro (sf-1) said : #10

#Juanjof
solved mean that I have filed a bug to the ubuntu team

https://bugs.launchpad.net/bugs/989658

;-)

I solved this using this tutorial http://www.icpep.org/mobile-series-4-display-problem-on-ubuntu-10-10-or-higher/ but after updating the OS yesterday everything is messed up.. Wish I did not include xorg updates :(

:D I removed the driver on software center named: X.orgXserver -- intel i8xx, i9xx, display driver and all dbg symbols. I also removed all VAAPI driver for intel G45 & HD Graphics. Its back to normal, I think the update previously installed this drivers after the update. I'll be careful from now... I'm using acer aspire 4736...