External Monitor Issues

Asked by Hannah Williams on 2011-12-16


I am trying to connect 2 external monitors to my HP laptop. I purchased a HP USP graphics adapter for this. But I am having a few issues, I am using linux with Ubuntu 10.04.3.

My new monitor which is Samsung, when I connect directly via the DVI port, does not work. I select detect monitors, and no option appears. The other monitor which is HP does work when I do this.

Using the Ubuntu Software Centre downloaded the Nvidia binary X.org driver, but when I select System - Administrator - Hardware Drivers, it says "No propriety drivers are in use on this system"

Can you help?



Question information

English Edit question
Ubuntu xserver-xorg-video-intel Edit question
No assignee Edit question
Last query:
Last reply:

Can you give the output of:

sudo lshw -C display; lsb_release -a; dpkg -l | grep nvidia


       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:28 memory:d0000000-d03fffff memory:c0000000-cfffffff(prefetchable) ioport:4050(size=8)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid
ii nvidia-173 173.14.22-0ubuntu11 NVIDIA binary Xorg driver, kernel module and
ii nvidia-173-dev 173.14.22-0ubuntu11 NVIDIA binary Xorg driver development files
ii nvidia-173-modaliases 173.14.22-0ubuntu11 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-96 96.43.17-0ubuntu1.1 NVIDIA binary Xorg driver, kernel module and
ii nvidia-96-dev 96.43.17-0ubuntu1.1 NVIDIA binary Xorg driver development files
ii nvidia-96-modaliases 96.43.17-0ubuntu1.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-common 0.2.23 Find obsolete NVIDIA drivers
ii nvidia-current 195.36.24-0ubuntu1~10.04.1 NVIDIA binary Xorg driver, kernel module and
ii nvidia-current-dev 195.36.24-0ubuntu1~10.04.1 NVIDIA binary Xorg driver development files
ii nvidia-current-modaliases 195.36.24-0ubuntu1~10.04.1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-glx-173 173.14.22-0ubuntu11 Transitional package for nvidia-glx-173
ii nvidia-glx-185 195.36.24-0ubuntu1~10.04.1 Transitional package for nvidia-glx-185
ii nvidia-glx-96 96.43.17-0ubuntu1.1 Transitional package for nvidia-glx-96
ii nvidia-settings 195.36.08-0ubuntu2 Tool of configuring the NVIDIA graphics driv

You have ALL the nvidia drivers installed, this will cause a whole lot of pain.

If you run:

sudo apt-get --purge remove nvidia-173 nvidia-173-dev nvidia-96 nvidia-96-dev nvidia-current nvidia-current-dev nvidia-glx-173 nvidia-glx-185 nvidia-glx-96 nvidia-settings

Then reboot you will be using the open driver. Does your system have that stupid dual GPU nvidia+intel crap?

Ok thanks, I ran that command but I'm not sure what the GPU Nvidia*intel is, or where I would find if my system is using it.
(sorry I'm not that knowledgeable on Ubuntu/Linux, I only just started using it)

The driver the system have when I enter command lspci | grep VGA
"00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)"

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Can anybody help me, the issue was not resolved, the monitor still does not work?

José Antonio Rey (jose) said : #7

Ok. Please follow these steps:

1.- Search the values of HorizSync and VertRefresh of your monitor.
2.- Open a terminal and type "sudo X configure :1" without quotes. This will create a new xorg.conf file.
3.- In the same terminal, type "gksu gedit xorg.conf.new" without quotes. This will open a text editor with the file that you have just created in there.
4.- You will see that it is divided in sections. Search for the Monitor section, and before the EndSection line of that section, add this two lines, without quotes:
"HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0"

5.- Replace the values in there with the values found in step 1.
6.- Save and close the file. If you want to, you can put it into a pastebin so I can check it before you move. If you do not want to, then move on to the next step.
7.- In a terminal, type "sudo mv xorg.conf.new /etc/X11/xorg.conf" without quotes. This will move the file to its correct position.
8.- Restart the PC.

In case it does NOT works, copy this command into a paper: "sudo rm /etc/X11/xorg.conf", and boot into text mode, to enter this command without quotes and remove the file. If it works, please ignore this step.

Can you help with this problem?

Provide an answer of your own, or ask Hannah Williams for more information if necessary.

To post a message you must log in.