display shows unknown in ubuntu 11.10

Asked by santhoshnsscoe on 2011-12-11

when i go to system settings and click on displays, it shows unknown. not able to change resolution or rotation. Both shows unknown. All the screens are fully stretched. How can i reset or change the settings. There is no options to do it.

santhosh@santhosh-Aspire-4736:~$ sudo lshw -C video; lsb_release -a
[sudo] password for santhosh:
  *-display:0 UNCLAIMED
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:5120(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:d3400000-d34fffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

Question information

English Edit question
Ubuntu xserver-xorg-video-intel Edit question
No assignee Edit question
Last query:
Last reply:

you may need an xorg.conf file in /etc/X11 your display hardware (monitor) is not reporting EDID so the driver is not loading for you

how to do this.. can you explain me in detail.... or give me a good reference...

how to do this.. can you explain me in detail.... or give me a good reference...

José Antonio Rey (jose) said : #4

Please follow these steps:

1.- Search the values of HorizSync and VertRefresh of your monitor.
2.- Open a terminal and type "sudo X configure :1" without quotes. This will create a new xorg.conf file.
3.- In the same terminal, type "gksu gedit xorg.conf.new" without quotes. This will open a text editor with the file that you have just created in there.
4.- You will see that it is divided in sections. Search for the Monitor section, and before the EndSection line of that section, add this two lines, without quotes:
"HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0"
5.- Replace the values in there with the values found in step 1.
6.- Save and close the file. If you want to, you can put it into a pastebin so I can check it before you move. If you do not want to, then move on to the next step.
7.- In a terminal, type "sudo mv xorg.conf.new /etc/X11/xorg.conf" without quotes. This will move the file to its correct position.
8.- Restart the PC.

In case it does NOT works, copy this command into a paper: "sudo rm /etc/X11/xorg.conf", and boot into text mode, to enter this command without quotes and remove the file. If it works, please ignore this step.


i am not able to get the HorizSync and VertRefresh of my monitor.

i used sudo ddcprobe, but didnot get anything list the above one.

there is no xorg.conf file, I created one in /etc/X11

santhosh@santhosh-Aspire-4736:~$ ls /etc/X11
app-defaults default-display-manager rgb.txt xinit Xreset Xresources Xsession.d Xwrapper.config
cursors fonts X xkb Xreset.d Xsession Xsession.options

José Antonio Rey (jose) said : #6

Can you please delete that xorg.conf file? It will interrupt the steps I gave you. What's the model of your monitor?

Ifyou make an xorg.conf file, it will be obeyed. A default install doesn't ship with one but some cheap monitors need one.

Jose sounds like he has a plan though

Can you help with this problem?

Provide an answer of your own, or ask santhoshnsscoe for more information if necessary.

To post a message you must log in.