Ubuntu

My display would be died away if I will install more new kernel than 2.6.35-22-generic

Asked by deleter24 on 2011-07-16

Machine configuration: Acer Aspire 5734Z, Intel Dual-Core 2.3 GHz, 2GB DDR3 Memory, Mobile Intel 4(R) Series Express Chipset Family

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
deleter24
Solved:
2011-07-21
Last query:
2011-07-21
Last reply:
2011-07-18
Chris (fabricator4) said : #1

You'll have to give us some more details on your problem. What is the nature of your display problem. Please post the output of :
lspci
on the command line.

Chris

Or are you saying that you have too many kernels listed in your boot menu?

deleter24 (igorek-sm) said : #3

Excuse me, I had an error in "that", fixed it to "than"

Your problem description still doesn't make sense, though. What does "would be died away" mean? As Chris asked, what is the nature of your display problem? As I asked, are you asking about how to remove kernels from the listing in the boot menu?

Sam_ (and-sam) said : #5

## Howto remove older kernel images.
## Make sure it isn't the one currently booted, keep at least previous one.
http://jaypeeonline.net/tips-tricks/howto-remove-old-ubuntu-kernels/
http://chrisjean.com/2009/03/05/cleaning-out-old-linux-kernels-in-ubuntu/

## Clean up package cache.
Open a terminal: ctrl+alt+t
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove

If possible you can boot to recovery mode, option 'root shell' and issue same cmds; no need for 'sudo' then.
https://wiki.ubuntu.com/RecoveryMode
http://unixlab.blogspot.com/2009/08/exploring-ubuntu-recovery-mode.html

https://help.ubuntu.com/community/UsingTheTerminal
https://help.ubuntu.com/community/AptGet/Howto

https://help.ubuntu.com/community/Diet%20Ubuntu

deleter24 (igorek-sm) said : #6

No, I need old kernel (in particular, 2.6.35-22-generic) to boot the system. I mean that my monitor goes black when I start using the new kernel (normal room light). But in bright light you can see the barely visible background and cursor. Upper and lower panels are absent. Does it means that my graphic card is not support more new kernel than 2.6.35-22-generic?

You may be able to boot the new kernel if you specify the nomodeset boot option. See https://help.ubuntu.com/community/BootOptions.

deleter24 (igorek-sm) said : #8

Thanx, Eliah Kagan, this boot option helped me, but I'm having a new problem now. Display resolution is 1024x768 instead of 1366x768. Compiz isn't working. I think that this problem is linked with X-server, right?

The new problem is related to the X server yes, though it should probably be classified as being about xserver-xorg-video-intel as well.

The new problem is a sufficiently different topic that I think you'll have better luck by posting a new, separate question about it, which you can do at https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+addquestion.

Since this question here was about how to successfully boot with your new kernel, you can mark this question as Solved. I recommend posting a link to this question in the description for your new question, and posting a link to the new question as a comment here.

deleter24 (igorek-sm) said : #10

OK, a new topic will be created and this topic will be closed. Thanks to all the authors of these replies!