Ubuntu

Display resolution won't set above 1024x768

Asked by Ed on 2011-06-07

I just purchased a Dell Inspiron 17R that has maximum resolution of 1600x900 (verified using Windows 7).
After installing Ubuntu 10.04LTS it turns out that the highest resolution that could be set through System->Preferences->Monitors was 1024x768 (the lowest was 800x600).
Since there was no xorg.conf file, I created one in /etc/X11 with the following contents:

Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
EndSection

Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 27-149
    VertRefresh 43-172
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
        SubSection "Display"
        Depth 24
        Modes "1600x900" "1280x800" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Now when System->Preferences->Monitors is opened it has: 1024x768, 800x600 and 640x480
The higher resolutions do not show. I also notice that 1024x768 refresh rate has jumped to 85Hz (from 60Hz previously).

How can I get to the best resolution the 17R has available?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
Ed
Solved:
2011-06-11
Last query:
2011-06-11
Last reply:
2011-06-08

Try changing:

Modes "1600x900" "1280x800" "1024x768" "800x600" "640x480"

To:

Modes "1600x900_60" "1280x800_60" "1024x768_60" "800x600" "640x480_60"

May help

Ed (echopsec) said : #2

Putting the _60 after each size didn't have any noticeable effect.

What is the output of:

sudo lshw -C display; lsb_release -a

Thanks

Ed (echopsec) said : #4

  *-display UNCLAIMED
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-d03fffff memory:c0000000-cfffffff(prefetchable)
ioport:4000(size=64)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.2 LTS
Release: 10.04
Codename: lucid

Thank you for your assistance.

Try changing:

Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
EndSection

To:

Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
EndSection

Ed (echopsec) said : #6

I made the change and restarted.

An error message popped up stating that Ubuntu was running in low graphics mode and:

   (EE)No devices detected

Allowing Ubuntu to come up in low graphics mode, I checked the resolution - 1024x765

Ubuntu Software Center shows that "X.Org X server -- Intel i8xx, i9xx display driver" is installed.

Using lspci | grep VGA returned
00:02.0 VGA compatible controller: Intel Corporation Device 0116 (rev 09)

Perhaps a special intel driver?

Ed (echopsec) said : #7

So thinking there was a solution by Mantas Kriaučiūnas responding to bug #590504, I used the Update Manager to get the latest updates (2011-6-09).

The xorg.conf file was as originally described with the driver as "intel".

Still no solution.

Ed (echopsec) said : #8

The solution to this problem was to load Ubuntu 11.04.

Disappointed that Ubuntu 10.04 Long Term Support did not support this with appropriate updates.

Also was disappointed that Firefox 4.0 (distributed with Ubuntu 11.04) no longer supports json bookmark files (since all my bookmarks were backed up this way). Actually the new Firefox doesn't even have the "Import and Backup" button said to be in the Library window (is this a problem with the Ubuntu distribution?). Fortunately my Windows machine still had an older version of Firefox and I was able to import into Firefox the json file and have Chrome suck them out of Firefox, whence I created an html bookmark file using Chrome.

I now use Chrome because I can't get the bookmarks into Firefox (because of the missing "Import and backup" button).

Thats because firefox sucks. I believe people tout it as "good" due to habit of using it rather than what is actually decent. When they use ANY other browser they quickly see the browser is rubbish