probleme with my intel 4500 in ubuntu 11.04

Asked by Dzconception on 2011-05-22

hi

i have a problem with ubuntu 11.04 and my emachines e727 with graphic card intel 4500 gma hd

black screen after installation of ubuntu 11.04 . i read that is a general problem sow can i have some solutions

thenks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-22
Last reply:
2011-05-23

Try the boot option:

nomodeset

Dzconception (dzconception) said : #2

Try the boot option:

nomodeset

NO THINGS!!!!!!!!!!!!!!!!!!!!!!!!!

"NO THINGS!!!!!!!!!!!!!!!!!!!!!!!!!"

What does that mean?

Does that mean you tried it, and it didn't work? What, if anything, happened when you tried it?

delance (olivier-delance) said : #4

Do you get boot menu (Grub) or do you have black screen after selection of screen ?
Do you get a whole black screen or a prompt at upper left ?
New video drivers will be delivered in coming version 39 of kernel, not yet included in Ubuntu.

Dzconception (dzconception) said : #5

i have a black screen with low luminosity

delance (olivier-delance) said : #6

Is it a laptop, a desktop or a net book ? There is a bug on back light on some laptop and net book.
If you connect an external monitor, do you get a black screen also ?
Could you check if Bug linked to your question (at top right of this page) describes your problem.

Dzconception (dzconception) said : #7

yes
i have netbook emachines e727 and when i connect it to an external monitor i have a good display

delance (olivier-delance) said : #8

Please subscribe the bug to:
  be informed of progress, workaround and fix
  make this bug more critical
I can't do more for you (except if you want to go back to 10.10).

Dzconception (dzconception) said : #9

hi

i'm on 10.10

You said "i have a black screen with low luminosity" and "i have netbook emachines e727 and when i connect it to an external monitor i have a good display". This indicates that you are suffering from bug 765438. In addition to subscribing to that bug, has you have done, I recommend you indicate that it affects you, using the green "This bug affects..." link near the top of the bug page, if you have not done so already.

Fortunately, there are three workarounds for this problem:

(1) https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/comments/2

(2) If that doesn't work, you can try the workaround described in the bug's description, i.e., after booting, run this command (in a Terminal window or virtual console) to manually set your backlight to the highest brightness:

sudo setpci -s 00:02.0 F4.B=00

(If that works, you can set up your computer to run that automatically as part of the start-up process.)

(3) If that doesn't work either, downgrade your kernel to the 2.6.36-series, which does not seem to suffer from this problem. However, since you're running Ubuntu 10.10, you may already be using a 2.6.36-series kernel, so this might not apply. You can check by running the command "uname -r".

(4) Try using a patched kernel and power manager, as described at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/comments/11.

If you have trouble implementing any of these workarounds, please feel free to post another reply in this question to get help.

Sorry, in workaround (3) I meant that you could downgrade to the 2.6.35-series.

Can you help with this problem?

Provide an answer of your own, or ask Dzconception for more information if necessary.

To post a message you must log in.