Ubuntu 11.04 update video disaster

Asked by Paul Gochin on 2011-04-30

I just allowed the ubuntu 11.04 update to install and the video is hopelessly screwed up. I tried classic mode and it still does not work. Is there anything that can be done or is my only option to reformat the disk and re-install ubuntu 10?

Question information

Please tell the video card do you have ?

If you are unsure of the video card you have:

- press ctrl+alt+f1
- made login with your user and password
- type: lspci | grep -i vga

Paul Gochin (pmg1) said : #2

The computer is a Dell Dimension B110
The response to lspci is:
00:02.0 VGA compatible controller: Intel 82865G Integrated Graphics Controller (rev 2)

By the way - thanks for the quick response!

Please copy-paste the following commands into the Terminal:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get dist-upgrade

Then reboot the PC and retest.

Paul Gochin (pmg1) said : #4

I followed the instructions but the problem is the same. The main desktop does not paint menus correctly. In general they are black. The text flashes for a fraction of a second when you mouse-over a selection.

I was able to select a tools menu that lets you set system settings. This window worked better, I was able to make selections in it. However a shadow of this window remained if you move it.

The main desktop still appears to be having a problem.

Paul Gochin (pmg1) said : #5

I found a posting on the internet that explained how to install the unity-2d desktop

http://www.unixmen.com/linux-tutorials/linux-distributions/linux-distributions4-ubuntu/1540-top-things-to-do-after-installing-ubuntu-1104-natty-narwhal

This seems to have solved my problem.

Antal Buss (antal.buss) said : #6

My video problem in Natty (random swapped pixel positions in some small screen regions) was solved after update using ppa:xorg-edgers/ppa.

My computer has Intel video card:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Mickg01 (mickg01) said : #7

Paul, explain how that site solved things?
Before upgrading I trid to run from USB flash drive and get the symptoms you describe except I can't open anything. When I click anywhere the screen goes black from top left to the point I click on. So I'm very inclined to say the Dell B110 Can't be upgraded to Natty.

Paul Gochin (pmg1) said : #8

The link explained how to use a legacy 2D window manager instead of the new default 3d manager that installs with 11.04

Mickg01 (mickg01) said : #9

OK This B110 Won't boot from a DVD to anything except a BusyBox prompt and booting from USB Flash I can't open a terminal not even with Ctrl+Alt+T. Yet it runs 10.10 perfectly.

As you got the main desktop does not paint menus correctly. In general they are black. The text flashes for a fraction of a second when you mouse-over a selection.

Clicking left mouse anywhere on the page causes large sections to go black for a long while so I'm inclined to not upgrade as it has an important Database on it. It actually looks more like Ubuntu Classic than Unity anyway and the machine has a full 2 Gig of memory.

I think I'll keep it at 10.10 for now.

Thanks